Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I click the icon, the splash screen will come up, and then about half way, it will disappear, I can't get it to work at all, any possible solutions?? I tried to get Terminal output, but I couldn't seem to get anything

share|improve this question
    
There wasn't any output in the terminal? We are going to need more information to have any idea on what the problem is. –  Alvin Row Oct 22 '10 at 3:52
    
Is there any OOo process running in the background? (Have a look in the System Monitor.) –  JanC Oct 22 '10 at 4:26
    
What should I run to get some output? And no, there isn't any other processes –  Grayson Oct 22 '10 at 5:33
    
Maybe reinstall all OOo packages (by Synaptic) ? –  Extender Oct 22 '10 at 7:52

2 Answers 2

Log as the guest user, to do this click on the shut-down icon on the right and in the menu that appears choose "Guest session". Try to start openoffice in this new session.

If it does start, then it's likely that your profile is corrupt. Get back to your real session (close the guest one with the shut-down menu). Click on your home on the Places menu, then on the View Menu select Show Hidden Files. Locate a directory called .openoffice.org, rename it to something different. Try to start OpenOffice again.

Note that you will lost all your settings for OpenOffice.

share|improve this answer

I had a similar problem with Monodevelop only about a week or so ago. It was caused by the permissions for the settings folder getting mutated (howsoever...) during a system update.

I had to delete the folder from the terminal (sudo) and then start it again.

Try AltF2 gksu openoffice.org and see if it runs then. If it does, then it is permissions. (I guess you can also use strace openoffice.org to check for permission related errors).

You can:
Either: Just delete the settings folder (.openoffice.org) and restart openoffice and it'll work.

Or: Rename the settings folder to keep a backup just in case and then start openoffice. [see comments below]

share|improve this answer
1  
I recommend to rename the folder .openoffice.org. If generating a new .openoffice.org folder didn't help, then you can easy set the folder back –  Bernard Decock Oct 22 '10 at 18:21
    
That is a good point. However, I could afford to delete because 1) I was certain there was a permission error, 2) My installation was very new and didn't have much in terms of customization, 3) I was being able to run Monodevelop with sudo every time without fail which meant it would create the folder if it wasn't found, considering it a "first run" situation (this is in fact what I tried to achieve). –  Mussnoon Oct 22 '10 at 19:00
    
It's a permission issue apparently, and now how do I fix thing... for good? –  Grayson Oct 22 '10 at 23:49
    
Either of the two ways I mentioned should let you run openoffice again. If by "fix for good" you mean stop this from happening again, then I don't think there's any way to do that as it seems to happen at random times for varying (apparent) reasons. –  Mussnoon Oct 23 '10 at 0:11
    
Well, as for now, it's being very constant, in the factor that it doesn't work :/ –  Grayson Oct 23 '10 at 1:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.