Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get my new Bamboo Pen&Touch tablet to work on ubuntu.

I tried following the guide on this page; I installed and updated the wacom-dkms package, and nothing.

I followed the guide on this page; I upgraded the xf86-input-wacom package, and ran all the commands in Appendix 1: still nothing.

I know that Ubuntu recognizes it, because when I run "lsusb" it shows up as "Bus 005 Device 003: ID 056a:00de Wacom Co., Ltd "

Anyone know what I am doing wrong? If I can't get it to work, it's not a huge deal, because it works just fine on Windows. It would make things a lot easier if I don't have to keep OS-hopping, though--especially with Windows' long boot times... :-}

share|improve this question

1 Answer 1

up vote 5 down vote accepted

The build instructions in the linked forum post are working, but not if you combine it with the PPA method. The PPA of doctormo contains outdated sources which won't work for your CTH-470 Pen & Touch.

When following the instructions from Appendix 1, you will have to run it each time your kernel updates against the new kernel. Using DKMS is recommended which will automatically create the kernel modules each time your kernel is updated. I've made the updated packages available on ppa:lekensteyn/wacom-tablet (see also What are PPAs and how do I use them?)

sudo add-apt-repository ppa:lekensteyn/wacom-tablet
sudo apt-get update
sudo apt-get install wacom-dkms

On 15 April 2012 I've added an upstream patch for supporting the Cintiq 24HD, published for Oneiric and Precise (version 0.12.1-0ubuntu1~ppa4).

share|improve this answer
    
Thank you very much, it works fine now! –  Anthony Dec 15 '11 at 18:12

protected by Community Dec 19 '11 at 14:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.