Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the nightly build of Chromium using this script I created.

I have set it as default web browser, although opening URLs via gnome-open and xdg-open just opens a new tab.

Using the executable file works as expected. What could the problem be?

update-alternatives --query gnome-www-browser output:

Link: gnome-www-browser
Status: auto
Best: /opt/chromium-nightly/chrome
Value: /opt/chromium-nightly/chrome

Alternative: /opt/chromium-nightly/chrome
Priority: 1200

Alternative: /usr/bin/firefox
Priority: 40

update-alternatives --query x-www-browser output:

Link: x-www-browser
Status: auto
Best: /opt/chromium-nightly/chrome
Value: /opt/chromium-nightly/chrome

Alternative: /opt/chromium-nightly/chrome
Priority: 1200

Alternative: /usr/bin/firefox
Priority: 40

xdg-settings get default-web-browser output:

chromium-nightly.desktop

cat /usr/share/applications/chromium-nightly.desktop output:

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Chromium Nightly
Comment=Browse the Web
Exec=/opt/chromium-nightly/chrome
Icon=/opt/chromium-nightly/product_logo_48.png
share|improve this question

closed as too localized by Marco Ceppi Dec 27 '12 at 18:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, –  Ringtail Mar 23 '12 at 21:36

Browse other questions tagged or ask your own question.