Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a ubuntu orchestra server setup and I'm trying to install some desktop ubuntus across the network. The version I am trying to install is 11.10. My preseed file is like this:

# Preseeding only locale sets language, country and locale.
d-i debian-installer/locale string en_US

# Enable extras.ubuntu.com.
d-i apt-setup/extras    boolean true

# Install the Ubuntu desktop.
tasksel tasksel/first   multiselect none

# Keyboard selection.
# Disable automatic (interactive) keymap detection.
d-i console-setup/ask_detect boolean false
d-i keyboard-configuration/layoutcode string br

# Controls whether or not the hardware clock is set to UTC.
d-i clock-setup/utc boolean true

# You may set this to any valid setting for $TZ; see the contents of
# /usr/share/zoneinfo/ for valid values.
d-i time/zone string America/Sao_Paulo

### Account setup
d-i passwd/root-login boolean false
d-i passwd/make-user boolean true
d-i passwd/user-fullname string Ubuntu User
d-i passwd/username string ubuntu

# Normal user's password, either in clear text
d-i passwd/user-password-crypted password $1$ZgNbzcXq$hUR0CnHVtYAvNNNnA2.br1

### Partitioning
d-i partman-auto/disk string /dev/sda
d-i partman-auto/method string regular
d-i partman-auto/purge_lvm_from_device boolean true
d-i partman-lvm/device_remove_lvm boolean true
d-i partman-md/device_remove_md boolean true
d-i partman-lvm/confirm boolean true
d-i partman-auto/choose_recipe select atomic
d-i partman-auto/expert_recipe string                         \
  boot-root ::                                            \
          40 50 100 ext4                                  \
                  $primary{ } $bootable{ }                \
                  method{ format } format{ }              \
                  use_filesystem{ } filesystem{ ext4 }    \
                  mountpoint{ /boot }                     \
          .                                               \
          1000 1500 2000 ext4                              \
                  method{ format } format{ }              \
                  use_filesystem{ } filesystem{ ext4 }    \
                  mountpoint{ / }                         \
          .                                               \
          1000 1500 100000000 ext4                        \
                method{ format } format{ }              \
                  use_filesystem{ } filesystem{ ext4 }    \
                  mountpoint{ /home }                         \
          .                                               \
          64 512 300% linux-swap                          \
                  method{ swap } format{ }                \
          .
d-i partman-partitioning/confirm_write_new_label boolean true
d-i partman/choose_partition select finish
d-i partman/confirm boolean true
d-i partman/confirm_nooverwrite boolean true

### Apt setup
# You can choose to install non-free and contrib software.
d-i apt-setup/non-free boolean true
d-i apt-setup/contrib boolean true
d-i apt-setup/services-select multiselect security
d-i apt-setup/security_host string security.ubuntu.com
d-i apt-setup/security_path string /ubuntu

### Mirror settings
d-i mirror/country string manual
d-i mirror/http/hostname string ubuntu.mirror.pop-sc.rnp.br
d-i mirror/http/directory string /ubuntu
d-i mirror/http/proxy string

### Package selection
#tasksel tasksel/first multiselect ubuntu-desktop
# Individual additional packages to install
#d-i pkgsel/include string openssh-server
popularity-contest popularity-contest/participate boolean false
d-i grub-installer/only_debian boolean true
### Finishing up the installation
d-i finish-install/reboot_in_progress note 

And I get an error on the installing packages phase. A menu shows up where I have the option to select install packages again, but even if I do I get the same error. What is wrong in this configuration file? In the tasksel part, besides none, I also tried ubuntu-desktop, but I get the same error.

Appreciate any help

Kelly

[Edit]

I made a change commenting out the partioning section and it worked! But I really need to specify the partitioning schema... :(

share|improve this question
    
It would help if you would post the error you are getting. –  bodhi.zazen Dec 15 '11 at 17:27
    
The message is: The installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: select and install software –  Kelly Goedert Dec 16 '11 at 9:42
    
Kelly, were you able to get this resolved? I'm doing a preseed remastered CD of Ubuntu 11.10 and am running into the same problem. Any advice would be appreciated! –  user48940 Mar 3 '12 at 0:12
add comment

1 Answer 1

OP has resolved the issue themselves

I made a change commenting out the partioning section and it worked! But I really need to specify the partitioning schema... :(

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.