Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the latest kernel version (3.0.0-15) through the Muon package manager of Kubuntu 11.10 but when I reboot the system it doesn't appear on grub list so I can use only the 3.0.0-12 kernel version. Synaptic reports that it's installed the kernel 3.0.0-14 version too but it doesn't appear too. The 3.0.0-14 and 3.0.0-15 versions didn't have the kernel image installed so I tried to install them but they don't appear on grub list in any case. Any idea? Many thanks in advance!

share|improve this question
    
You have to update the grub list. I am not sure whether sudo update-grub is all you need. –  queueoverflow Dec 15 '11 at 15:04
    
Please post your /boot/grub/grub.cfg and the output of ls /boot/ –  Jordan Uggla Apr 4 '12 at 7:14
add comment

1 Answer

Try to:

sudo update-initramfs -u

and

sudo update-grub

Earlier with the Kubuntu: http://kubuntuforums.net/forums/index.php?topic=3104599.0

The package manager should do this by default. Looking old logs:

Log of sudo apt-get dist-upgrade Sat Dec 10 21:43:55 2011

The following NEW packages will be installed:
linux-image-3.0.0-14-generic

Setting up linux-image-3.0.0-14-generic (3.0.0-14.23) ... Running depmod. update-initramfs: deferring update (hook will be called later)

run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.0.0-14-generic /boot/vmlinuz-3.0.0-14-generic Generating grub.cfg ...

man update-initramfs:

NAME update-initramfs - generate an initramfs image

SYNOPSIS update-initramfs -c|-d|-u [-k version] [-t] [-v] [-b] [-h]

DESCRIPTION The update-initramfs script manages your initramfs images on your local box. It keeps track of the existing initramfs archives in /boot. There are three modes of operation create, update or delete. You must at least specify one of those modes.

   -u    This mode updates an existing initramfs.
share|improve this answer
    
I tried to do it but unfortunately it doesn't work :( –  dd87 Dec 15 '11 at 17:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.