Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my system today (usual minor package updates), and have not been able to boot into any 3-0-0-XX kernel since, despite the fact that I was using a 3.0 kernel just fine before today. I checked for questions that covered my problem and I found this question, and I tried the solution, but was still unable to boot. I've also checked for solutions in the Ubuntu bug database but I haven't been able to get any of them to work.

When I boot 3.0.0-14 (or -12 or -13) in recovery, all I get is a line like

rtc_cmos 00:05: setting system clock to <blah>

and nothing happens after that. There's no response to keyboard input, including Ctrl-Alt-Delete.

Does anyone know a solution to this problem? I'm booting in an old 2.6.38 kernel for now, but this will start getting obnoxious after I forget that I have to do this.

UPDATE:

The system is indeed totally unresponsive to keyboard input. Neither the Magic SysRq keys nor the Ctrl-Alt-F# will work. Changing video mode at startup also does not work.

There were lots of packages that were upgraded, but the ones that could mess up the boot as far as I could tell would only be the kernel and acipid. I reinstalled those, to no avail.

share|improve this question
1  
This doesn't solve your problem, but you can arrange for Ubuntu to automatically boot to the kernel you last used. Edit /etc/default/grub and set the options GRUB_DEFAULT="saved" and GRUB_SAVEDEFAULT="true". Then, run sudo update-grub. I've been doing this as I'm also affected by a bug in the 3.0 kernels. –  Scott Severance Dec 16 '11 at 1:01
    
Ah, that's a little more palatable. Thanks for the tip. –  John Moeller Dec 16 '11 at 4:23

1 Answer 1

The rtc_cmos message is one of the last messages before many of the graphical boot screen programs take over.

So, debugging thoughts: can you check the timestamps of packages in your package cache (/var/cache/apt/archive) and see what packages installed? What happens if you try switching virtual terminals after waiting a sufficient amount of time for bootup? (ctrl+alt+f1/ctrl+alt+f2/etc.). Is it locked up or just locked? Do the Magic SysRq keys work?

My guess is that this is a graphics card/graphics related situation, so to eliminate that option, it might be worthwhile to try booting with a different framebuffer configuration. See http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Linux_video_mode_numbers

Of course, in the interim time, you can always reconfigure grub to default to a different kernel. Check out /etc/default/grub.

share|improve this answer
    
Ah, OK. I'll have to try tomorrow, but I will try your suggestions. –  John Moeller Dec 15 '11 at 2:32
    
No luck. See my update above. –  John Moeller Dec 15 '11 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.