Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to set --no-desktop via gconf for nautilus, I use OpenBox. I used to just set it like this

# Disable Nautilus desktop.
gconftool-2 -s -t bool /apps/nautilus/preferences/show_desktop false &
# Do not let Nautilus set the background image.
gconftool-2 -s -t bool /desktop/gnome/background/draw_background false &

However, I find this does not work in Ubuntu 11.10. Has something changed in gconf? Might it have anything to do with Gsettings? In the mean time, I just added --no-desktop to my .desktop shortcuts. This is not a solid long term solution for me, for a few reasons. Anytime you upgrade the nautilus package, those changes will overwrite. Much more importantly, Anything that launches nautilus another way wont use --no-desktop. If anyone can help, it would be much appreciated.

BTW: gconf-editor let me view my settings, but no schema for nautilus even existed.

share|improve this question

2 Answers 2

up vote 13 down vote accepted

Yes, in Gnome 3, Gconf is being replaced by DConf, which is accessed through GSettings. You can use dconf-editor from the dconf-tools package to explore. It's very similar to gconf-editor.

The entries your looking for are located at org -> gnome -> desktop -> background

Uncheck draw-background AND show-desktop-icons

enter image description here

No more openbox menu and wallpaper problems :)

share|improve this answer
    
can you update your answer ? I tried the solution but it's still showing up the nautilius background even when I uncheck the draw-background –  Suhaib Nov 21 '12 at 17:25
    
am using 12.10 Ubuntu + openbox –  Suhaib Nov 21 '12 at 17:46
2  
The question was about 11.10. Things may have changed since then, and I don't use 12.10. Perhaps a new answer should be added? –  Jo-Erlend Schinstad Nov 25 '12 at 9:17

The setting mentioned in Jo-Erlend Schinstad's answer has been deprecated and I can't find a new equivalent setting. A workaround is to let the file manager set the background but set the alpha to zero. The command for this is

dconf write /org/gnome/desktop/background/picture-opacity 0

or you can use the dconf-editor gui to set it as discussed in Jo-Erlend Schinstad's answer.

The setting to hide the desktop icons is still the same:

dconf write /org/gnome/desktop/background/show-desktop-icons false
share|improve this answer
    
For me it was sufficient to set the show-desktop-icons to false. –  elzapp Feb 10 at 8:50
1  
Just tested and yep, that seems to work. I'll try it out on some more computers before I edit the answer because it seems weird... –  dshepherd Feb 10 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.