Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to know whether I can run compiz on my Nvidia card to speed things up. It's a Dell XPS15 laptop but I'm mostly using it as a desktop, so battery life is not important. Apparently my Intel integrated card is able to run unity 3D, but my Nvidia GT 420M is not. Here's the output of unity_support_test, both with optirun and without it:

manuhalo@Ubuntu-XPS-L501X:~$ optirun /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce GT 420M/PCI/SSE2
OpenGL version string:  4.1.0 NVIDIA 280.13

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  no
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

manuhalo@Ubuntu-XPS-L501X:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string:  2.1 Mesa 7.11

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

Any ideas of why this is happening? Thanks in advance to anyone able to shed some light on this.


What I have tried:

Installed the v290 drivers from the x-stable PPA.

Tried forcing Unity-3D to work by telling Unity to ignore the unity-support-test results

i.e.

gksudo gedit /etc/environment

add the following UNITY_FORCE_START=1 to the end of the file.

share|improve this question
    
Possibly you should use the nvidia v290 driver instead of the v280 driver - launchpad.net/~ubuntu-x-swat/+archive/… –  fossfreedom Dec 14 '11 at 13:14
    
@fossfreedom thanks for your suggestion! I just updated the drivers from the repository you mentioned, but unfortunately got the same result, still GLX texture from pixmap: no. –  manuhalo Dec 14 '11 at 20:41

2 Answers 2

You can't use the nvidia you on an optimus laptop to render the desktop and effects, the Intel card as of now can only do that. Only applications can be run with the nvidia card. I sold my optimus laptop and got a Sony viao with an i7-2820,and dedicated gt540. Intel graphics are not wired up in this laptop so the nvidia renders everything, and its soooo much better than that horrible optimus.

share|improve this answer

My optimus settings show the same. But bumblebee works. I have a GT540 too. It shows that it doesn't support Unity 3d but it does. As a matter of fact both VGA's do.

Checkout this link to install Bumblebee:
http://sachithdhanushka.blogspot.com/2012/02/bumblebee-30-for-ubuntu-1110.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.