Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Unity the user name is shown in the panel. Is is possible to make it so that it is not displayed? For example it would be nice if only the icon but not the user name were displayed.

The displayed user name

share|improve this question

6 Answers 6

up vote 20 down vote accepted

(If you dont want to install other programs)

Open a terminal and use this command to disable the name display

gsettings set com.canonical.indicator.session show-real-name-on-panel false

enter image description here

To revert it back simple use

gsettings set com.canonical.indicator.session show-real-name-on-panel true

enter image description here

After using one of the commands you need to log off and back on or use unity --replace & to reload unity.

You can also remove the user switching menu from the indicator panel with

gsettings set com.canonical.indicator.session user-show-menu false

enter image description here

and enable it with

gsettings set com.canonical.indicator.session user-show-menu true

enter image description here

but if you do so you will disable both the username and the user switching indicator. You cannot remove the user switching menu while keeping the username indicator.

share|improve this answer
    
Thanks for the gsettings command, the more existing thing that it has autocomplete for the keys! –  Muhammad Hewedy Nov 2 '13 at 21:37

open dconf-editor, go to "apps -> indicator-session" and unmark "user-show-menu"

enter image description here

logout and login again

share|improve this answer
    
Thanks, works perfectly (so far). –  Pavel S. Oct 15 '11 at 22:01

Install package dconf-tools

sudo apt-get install dconf-tools

press Alt+F2 and run:

dconf-editor

In dconf-editor, navigate to apps > indicator-session and untick the option show-real-name-on-panel

enter image description here

Then reload unity to see the effect:

unity --replace

Or logout and login

share|improve this answer
    
You forgot to mention that I need to logout and login again for the changes to apply. Maybe it could be done by reseting Unity as well? –  N.N. Dec 14 '11 at 8:34
    
@N.N. Thanks :) i edited my answer unity --replace will be enough to see the change. –  Achu Dec 14 '11 at 8:48
    
This works well. Is there any other methods to accomplish the same, e.g. doing it via the command-line? –  N.N. Dec 14 '11 at 8:51
    
@N.N. Sorry :) i don't know ho to do that in command line yet. But i will include in the answer when learn one. –  Achu Dec 14 '11 at 8:55
    
Bruno posted a command-line solution askubuntu.com/a/87674/19490 . Oh, and as I commented to Bruno's post it might be an idea to include screenshots of the difference the settings makes makes to make your answer even better. –  N.N. Dec 14 '11 at 9:21

Install Ubuntu Tweak for Ubuntu 11.10 by installing the PPA here.

Once installed, go to the tweaks tab, and change the setting for "Show full name in panel". enter image description here

share|improve this answer
    
Could you please include a screenshot where it's shown how the settings for "Show full name in panel" can be changed? –  N.N. Dec 14 '11 at 14:10
    
Sorry, I'm not on my PC now, but I'll add one later. –  William Dec 14 '11 at 14:24

For 12.04 (should work on earlier versions also)

So, To disable user name displaying, there is two way: 1) Command Line 2) Graphical way.

1) Command Line

If you don't want the switching feature at all, no name and no user icon. Do this:

Open a terminal and execute this command to disable it. Then Logout and Login.

gsettings set com.canonical.indicator.session user-show-menu false

To re-enable, just change false to true

gsettings set com.canonical.indicator.session user-show-menu true

2) Graphical way (using Ubuntu-tweak)

  1. Install Ubuntu-tweak

  2. Open Ubuntu-tweak by typing the name in dash

    opening ubuntu-tweak from dash

  3. Go to the section TweaksSession indicator

    Go to Tweaks -> Session indicator

  4. Toogle the switch User indicator to Off state.

    enter image description here

(To revert the settings, just toogle the User indicator switch again)

That's it. Logout and Login again to see the change.

Below are screenshots before and after disabling the user name:

  • Before:

    enter image description here

  • After:

    enter image description here

share|improve this answer

Since Ubuntu 12.10 the user name is not displayed in the panel. Thus, you do not have to do anything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.