Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell laptop with Ubuntu 11.10 installed. It is the host for 3 virtual machines (also running Ubuntu 11.10) installed using KVM.

I need to recompile the kernel of each virtual machine for setting some networks options, but when trying to boot on the new kernel I get the following:

Gave up waiting for root device".... "ALERT! /dev/disk/by-uuid/(ID) does not exist".

What I have tried:

  1. rootdelay 50, 60, ... didn't work
  2. booting with pci=nomsi (and other options)... didn't work
  3. Deleting the partition and starting from scratch... got the same error.

Additional info:

  1. The kernel on my PC and VMs is 3.0.0.12-generic-pae
  2. The kernel I am trying to compile is 3.0.1
  3. There is no /etc/fstab when trying to boot from the new kernel
  4. The uuid that the new kernel is not finding is exactly the one I see on the /etc/fstab of the original kernel

Can anybody help me?

share|improve this question
add comment

migrated from serverfault.com Dec 14 '11 at 6:58

This question came from our site for professional system and network administrators.

1 Answer

up vote 1 down vote accepted

This is a bit of a guess; have you compiled in virtio block support to your new kernel if you're using it?

You probably want some/all of the following (certainly won't hurt to turn them on to try anyway):

CONFIG_VIRTIO
CONFIG_VIRTIO_BLK
CONFIG_VIRTIO_NET
CONFIG_VIRTIO_CONSOLE
CONFIG_VIRTIO_BALLOON

I suspect the top two are most important for this particular problem. If you're not using virtio then this is irrelevant, just say and I'll delete.

share|improve this answer
    
I already got it solved, this is the correct answer (for my case at least) –  marcocamejo Dec 17 '11 at 3:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.