Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just plugged in a Belkin Flip KVM to handle switching between my desktop and my Eee PC 1000. The mouse and monitor switch fine, but the separate keyboard does not work when the KVM switches to the netbook. The keyboard integrated into the netbook works fine, and the separate keyboard works fine when the KVM switches to the desktop.

This model of KVM runs the keyboard and mouse through a single USB, I suspect this is what is confusing the Eee PC.

How can I get the Eee PC to detect and use the seperate keyboard?

Both machines are running Oneiric.

share|improve this question

closed as too localized by Stefano Palazzo Jan 5 '12 at 15:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Have you tried using this KVM on another system, to isolate that it is an Ubuntu issue? –  Marco Ceppi Dec 13 '11 at 20:39
1  
Did you use this KVM switch with the Eee PC before this? –  rlemon Dec 13 '11 at 20:44
1  
what Flip switch.. there are 5 belkin.com/IWCatSectionView.process?Section_Id=206974 –  rlemon Dec 13 '11 at 21:53
1  
We need to know exactly what your switch model is, please add to the question. Also test this situation: boot the eee pc with the switch on the eee pc position, does the kb work? Flip it between the desktop and the eee pc, what works then in this scenario? On the eee pc do you have one of those USB ports that have constant power on them? Can you try the switch on that port (if it exists)? –  Bruno Pereira Dec 14 '11 at 9:09
1  
Please also add the output of lsusb with the switch connected, disconnected, with the switch activated to the eee pc, with the switch not activated to the eee pc. –  Bruno Pereira Dec 14 '11 at 9:10

2 Answers 2

up vote 4 down vote accepted

OK, firstly, thanks for your help everyone!

Secondly, the issue is resolved.

Somewhat embarrassing, but after scouring the internet and getting together a whole pile of info to post back here I took a minute to double-check the setup and found that I had accidentally swapped the plugs for keyboard and webcam. What an idiot!

For future reference the exact model of KVM is the Belkin Flip USB with audio, and it's now confirmed working perfectly with Ubuntu 11.10.

share|improve this answer
    
Thanks for adding this information instead of leaving the question abandoned. Can you click the green check box on your answer and mark it answered? –  Bruno Pereira Jan 5 '12 at 15:22

this issue is a hardware specific ... Unfortunately your switch is not supported by the laptop.. read here

as was pointed out to me this is actually the supported list - and as pointed out by you that your device is not listed - don't know if that means anything.

share|improve this answer
    
Thanks, but that's not the same KVM. Mine is a Belkin Flip, a desktop model. –  Seret Dec 13 '11 at 21:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.