Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok so I looked everywhere and I'm still not been able to find a solution for my problem.

I'm running Ubuntu 11.10, with Unity 3D and ATI Catalyst 11.11, I have an ATI Radeon HD 6870 and I have a monitor with a resolution of 1600x900 connected by DVI and a TV with a resolution of 1920x1080 connected by HDMI.

So what I want to do is to set a dual monitor configuration I've tried in the Catalyst using my monitor as first monitor and the TV as second and choosing the "Single display desktop (Multi-desktop)" on the TV properties but I didn't get any result, then I tried from the "Displays" section on Ubuntu and I got this message:

"The selected configuration for displays could not be applied required virtual size does not fit available size: requested=(3520, 1080), minimum=(320, 200), maximum=(1920, 1920)"

The only way that the configuration could work was my monitor on the top of the TV instead being side to side "so they don't exceed the resolution" but that don't work for me

So later and after reading a lot of posts I realize that that Catalyst have a bug and if I execute the command sudo amdcccle it starts the Catalyst and when I set up "Single display desktop (Multi-desktop)" on my second monitor (the TV) it ask me to restart so I can have that configuration (everything fine until here). But my problem is that when I restart my computer I got my first monitor fine but in my TV I got a blank screen and instead of the mouse I got an X, somebody know how to fix this??? and if that have something to do with the resolution?? because I'm planing to buy another 1600x900 monitor so I'll have a triple display configuration.

share|improve this question
    
Can you ask your second question as a new question? This system works best when there's one post per question, thanks! –  Jorge Castro Dec 13 '11 at 23:40

4 Answers 4

If you select the 1 desktop over multiple screens function in de catalyst control center and apply it.after a reboot you can set multiple monitors via the 'screens' dialog and there wont be a "big screen resolution"-error.

share|improve this answer

I had similar problems with the ATI driver not letting me use the screen configuration I wanted. In the end, I found that uninstalling the proprietary driver, and using the default open source driver was much more friendly. Uninstalling isn't as easy as it ought to be, but I think the instructions here should work. I had other problems though (related to the upgrade from 11.04), so I ended up reinstalling from clean, so I'm not totally sure if/how the uninstall works.

In 11.04 I found that the open source driver was not good enough to enable the 3D features in VirtualBox or WMWare player, but in 11.10 even that works. Unity 3D works fine with both.

I wouldn't say the drivers are perfect, but they work very nicely most of the time. In particular, changing the resolution settings in Display Settings sometimes has strange results (flickery screens, screens off entirely) - if you really want to know what your new settings look like, log out and in again to be sure. That's annoying, but really, how often do you want to use a different setup during a session?

share|improve this answer
    
Yes I tried that when I Installed Ubuntu 11.10 but those drivers gave me other problems besides this one, so I definitely have to stick with the Catalyst 11.11 drivers, right now the blank screen is my only problem –  Marvin Dec 13 '11 at 17:58
    
I'm curious what those other problems are? –  ams Dec 13 '11 at 20:31
    
The resolution, it'was like if the screen was bigger than my TV so I couldn't saw the entire screen, and the colors wasn't the best –  Marvin Dec 21 '11 at 1:08
    
@Marvin The 'screen bigger than my TV' problem is called Overscan. Sometimes the driver settings handle this, sometimes it's a display setting. Look for the word 'overscan' in the settings of both. The colors I can't help with, sorry. –  Tom Brossman Feb 29 '12 at 21:13

I had this problem too. I just checked the Xinerama box under display options and it is working now.

share|improve this answer

The way I got it to work on my machine was to:

  • open AMD Catalyst Control Center (Administrative)
  • click on Display Manager
  • in 'Multi-Display' tab, select Multi-display dekstop with display(s) 2
  • apply
  • reboot my machine

After that:

  • open System Settings
  • go to Display
  • uncheck 'Mirror displays'
  • select Launcher placement to only the first screen (on the left)
  • click Apply

This worked for me on Ubuntu 12.04 Precise Pengolin. Don't forget to set 'Tear Free' in AMDCCCE and you'll get a pretty good desktop running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.