Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to create a bootable USB stick of ubuntu-11.10-desktop-i386.iso using usb-creator-gtk on my ThinkPad X220. Usb-creator-gtk appears to work OK, but the resulting stick fails to boot either of my laptops. I tried two different USB sticks. Boot just shows a blinking cursor.

If I mount the USB stick, I see it has 729M of data on it.

One more clue: After usb-creator-gtk exits, the activity light on my USB drive continues to blink for a minute or so, and even after that's done, /media/XXXX-XXXX and /tmp/tmpXXXXXX remain mounted. I have been manually umounting them before pulling out the stick.

Is there any way to get debug output from usb-creator-gtk? Or is there a straightforward command-line alternative to usb-creator-gtk that would offer more debugging options?

UPDATE: In syslog, I noticed the error:

usb-creator-gtk[xxxxx]: segfault at 4 ip xxxxxxxxxxxxxxxx sp xxxxxxxxxxxxxxxx error 6 in libdbus-1.so.3.5.7[xxxxxxxxxxxx+xxxxx]

Turns out this is ubuntu bug #875758.

Is there an alternative to usb-creator-gtk? Ideally, a bash recipe that would help me isolate the problem and work around it?

share|improve this question
3  
Have you tried unetbootin - I find this far better that the default in Ubuntu: unetbootin.sourceforge.net –  fossfreedom Dec 13 '11 at 9:38
    
Also copying the ISO image to USB drive (not partition) with dd should work. –  enzotib Dec 13 '11 at 9:44
    
Thank you, fossfreedom. Unetbootin worked where usb-creator-gtk failed. –  Joe Dec 14 '11 at 2:53
    
@fossfreedom want to add that as an answer? –  Stefano Palazzo Feb 1 '12 at 11:39
    
@Stefano - not really - I dont think it answers the question directly. The OP seems to have disappeared - possible this question could be considered as abandoned? –  fossfreedom Feb 1 '12 at 12:51

1 Answer 1

  • Identify device (/dev/xxx) and unmount device
  • Device should be in FAT32 if not -> sudo mkdosfs -n 'USB-LABEL' -I /dev/xxx -F 32

Mount the iso file and copy content to USB device :

sudo mkdir /media/iso

sudo mount -o loop /path/to/ubuntu.iso /media/iso

cp -a /media/iso/. /USBMOUNTPOINT/

Make the device bootable :

sudo apt-get install syslinux mtools

syslinux -s /dev/sdd1

Rename the isolinux directory to syslinux and copy config :

mv /media/xxx/isolinux /media/xxx/syslinux

mv /media/xxx/syslinux/isolinux.cfg /media/xxx/syslinux/syslinux.cfg

Reboot your pc and change the boot-order in bios to USB.Now your ubuntu usb flash drive will booted up and you can install it.

share|improve this answer
    
will the USB have persistent storage? –  Ciro Santilli May 16 at 14:11
    
@CiroSantilli no, but you can manually create a casper-rw file (see pendrivelinux.com/how-to-create-a-larger-casper-rw-loop-file) and enable it by adding persistent to the kernel command line in syslinux/txt.cfg. –  Lucas Jul 29 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.