Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sorry for such a long post :) I'm not such an expert as I wanna be, but I'm still learning on my mistakes. Just recently I've encountered an problem with mounting USB flash memory sticks and external USB DVD recorder. After upgrading from 11.04 (which was fresh installed) to 11.10 I haven't use any USB devices except USB external disk which is always connected to one port and working properly, automatically mounted on every login and OS never asked or warned me for anything regarded with this device. But, when I plug in any of my two flash memory sticks - nothing happen. Right now, when I'm writing this, I have plugged in two flash sticks, both are from ADATA, one is C003/4GB, and another is C702/8GB. Both are tested on several other computers with Ubuntu, Debian or even with XP, and they're mounted without any problems and formatted on FAT32, and they're working on this computer before on earlier Ubuntu versions. I've tried to solve this problem in many ways founded on many Linux or Ubuntu forums, but it seams that my system is something different. So, some of listed results after few commands on Terminal are:

sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders, total 117210240 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e4de4

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048     4999167     2498560   82  Linux swap / Solaris
/dev/sda2   *     4999168   117209087    56104960   83  Linux

Disk /dev/sdb: 1500.3 GB, 1500299395072 bytes
255 heads, 63 sectors/track, 182401 cylinders, total 2930272256 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000ce22d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63  2930272064  1465136001    7  HPFS/NTFS/exFAT

Disk /dev/sdd: 8075 MB, 8075140608 bytes
255 heads, 63 sectors/track, 981 cylinders, total 15771759 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00036ae0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1              63    15759764     7879851    b  W95 FAT32

mount

    /dev/sda2 on / type ext4 (rw,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/tomislav/.gvfs type fuse.gvfs-fuse-daemon
(rw,nosuid,nodev,user=tomislav)
/dev/sdb1 on /media/074EC1A009B5F389 type fuseblk  
(rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)

lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 1058:1021 Western Digital Technologies, Inc. Elements 2TB
Bus 003 Device 002: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 008: ID 125f:c03a A-DATA Technology Co., Ltd. 
Bus 001 Device 005: ID 125f:c72a A-DATA Technology Co., Ltd. 

Also, by running gconf-editor and navigating through Apps-Nautilus-Preferences I noticed that there's no more two lines mentioned on many solutions: "Media_Automount" and "Media_Automount_Open", and after adding them manually - nothing new happen. Since I'm trying to solve this problem for three weeks now and I'm running out of time because I'll need to use my USB flash to transfer some big files from work computers to mine, and I have no choice but to kindly ask anyone to help me.

share|improve this question

closed as too localized by Oli Jan 23 '12 at 11:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

I succeeded with a command:

mount -t vfat /dev/sdc1 /mymountpoint

Change the 'sdc1' and 'vfat' according to your usb device and disk format type.

share|improve this answer

Thank you all for your efforts, I've had to made fresh install of Ubuntu 11.10 and after all upgrades everything is working again. I know that this isn't a solution of the problem, but if I only had more time to troubleshooting...

share|improve this answer

Try this link maby it help you .. http://blog.philippklaus.de/2011/11/solve-a-problem-with-usb-hdds-on-ubuntu-11-10/

Bye Greg

share|improve this answer
    
Sorry, that didn't help –  Tomislav Dec 13 '11 at 15:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.