Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is it possible to lock the spawn location of applications so they don't hide the unity bar? At the moment applications launch up the top left of the screen, pushing out my unity bar (which is really annoying) and just generally being hard to reach on my dual monitor setup.

Only some applications do this, however. I hoping there is some kind of way I can over-ride this and force all applications to start in the location they were last closed, or at the least be able to turn off the auto-hide of the unity bar.

Hoping we can come up with something here.

share|improve this question
    
If you are using unity-3d, (ubuntu session), & referring to un-maxed windows, then NO window should ever open over the launcher & cause it to hide. If however you are using unity-2d, due to a poor build of metacity in Sept., then the 2nd un-maxed window will always open over the launcher & hide it. You may wish to mention which unity you're using –  doug Dec 13 '11 at 1:56

1 Answer 1

Stop Unity Launcher to auto-hide:

1) Install ComfigCompiz Setting Manager (you find int in Ubuntu Software Center)

2) Open it, and at Desktop -> Ubuntu Unity Plugin -> In the Behavior tab for the Hide Launcher select "Never"

That's it.

Regarding setting fixed position for applications to launch, I don't know.

Cheers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.