Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've got as far as connecting this keyboard using the manual bluetooth configuration - I assume that since 11.10 is detecting it (from lsusb) then the keyboard configuration is correct. Fowever, only a few of the media keys are detected (email, vol+, vol-). showkey detects some more keycodes (418, 419, 420 for example), but xev does not.

Where should I be looking to determine at which layer the keys are missing?

share|improve this question

closed as too localized by jrg Mar 6 '12 at 15:54

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

In Natty I can change the keyboard model, and the DiNovo Edge is listed. In Oneiric I cannot find the list with the keyboard models (gnome-keyboard-properties). Maybe setxkbmap -model logidinovoedge works? –  elmicha Dec 12 '11 at 22:05
Tried it - no effect. –  Sean Houlihane Dec 12 '11 at 22:41
The last comment in askubuntu.com/questions/72562/… says that he used settings -> keyboard -> shortcuts and edited some shortcuts there. I'm not sure if that can work if xev doesn't even show your keys. –  elmicha Dec 12 '11 at 23:06
The keys I care about do not generate any input for that dialogue to process. The problem is that there are several layers of drivers involved and it is all now completely hidden, so I don't have any idea where to file a bug to start getting progress on this. –  Sean Houlihane Dec 13 '11 at 8:18
I agree, it's a bit messy. Are there any error messages in dmesg for these keys? wiki.edubuntu.org/Hotkeys/Architecture seems to be broken at the moment, but the Google cache works. Did you see /usr/share/doc/udev/README.keymap.txt.gz already? –  elmicha Dec 13 '11 at 9:58