Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Problem: Since Ubuntu 10.04 I can no longer adjust the background brightness of the built in LCD-Panel. The Laptop (Samsung Aura R700 Dillen - Nvidia 8600M GT GPU) is always on a very low brightness-level. Since Ubuntu 11.04 the below detailed solution doesn't work any more.

In Ubuntu 10.04 the solution to the backlight problem was rather "simple":

  1. Open nvidia-settings and create/save and merge a xorg.conf file.
  2. Open a Terminal and: sudo gedit /etc/X11/xorg.conf
  3. Once opened, in the "Device" section, add this line: Option "RegistryDwords" "EnableBrightnessControl=1"
  4. Save and exit. Reboot the machine.
  5. Done.

I want to do the same thing in Ubuntu 11.10, because this takes care of the brightness-adjust problem.**

How can I safely create and edit xorg.conf in Ubuntu 11.10? I can't find it and a lot of ppl suggest different methods how to create it again. Some are known to cause the computer to not boot correctly.

  • Adding the Voria-Tools PPA is not an option. I don't like installing untrusted PPA's. Also, I tried this before and it never worked.
  • I have tried the steps mentioned in the link Oli posted. A few of those steps made Ubuntu hang during bootup (editing Grub to add the ACPI-line for example; it always typed in something different - something was buggy there).
share|improve this question
1  
About half the questions on this site are related to Samsung backlight issues. Have you tried any of the fixed suggested in any of them? Here's one that worked for me (the udev method). Let me know and if it does and I'll close this as a dupe. –  Oli Dec 12 '11 at 21:29
    
Hi Oli, yes, I have tried the steps mentioned in the link you posted. A few of those steps made Ubuntu hang during bootup (editing Grub to add the ACPI-line for example; it always typed in something different - something was buggy there). I have also tried the Voria-Tools - without success. I tried a lot of different things, but none of them worked and caused other problems. A few days ago, I installed Ubuntu again and started fresh. So, in order to keep things clean this time, I'd like to stick to what I know works best (the steps mentioned in my Post, but for 11.10). Thanks! –  Oranges10e Dec 12 '11 at 21:44
add comment

1 Answer

up vote 2 down vote accepted

I finally fixed it! And even - without - the need of any Voria-Tools PPA or without the need to manually edit anything else, besides what I already posted. I have tried this on three Samsung Laptops - with success. All of them had the same issue (with brightness controls).

SOLUTION (for Ubuntu 11.04 and 11.10):

  1. Open nvidia-settings (you can find it via Unity-Dash)
  2. Go to "X Server Display Configuration"
  3. Click on "Save to X Configuration File"
  4. It will display an error: Failed to parse existing X config file ‘/etc/X11/xorg.conf’!
  5. Ignore the error. A new window pops up and asks you to save the X Configuration File.
  6. Leave everything as it is (/etc/X11/xorg.conf - do not merge, if you haven't done this before) and click on save. This will generate a new file for you.
  7. Open this new file with: gksudo gedit /etc/X11/xorg.conf
  8. Once the file is opened, do what I mentioned in my previous Post: Add this line to the Device section of the file:

    Option "RegistryDwords" "EnableBrightnessControl=1"
    
  9. Click on save and close the window.

  10. Reboot the machine. Brightness-controls should now be working and you should be able to use your FN-Keys to adjust brightness.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.