Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not duplicate to this nor this nor this one

Hello

There is a known bug with ATI driver (fglrx) and gnome-shell, I know. Just wondering why I can play 3D games with high graphic features using same driver (version 11.11)? also there is no problem with graphical effects of KDE and other programs using graphical environment, but there is problem with very simple effects of gnome-shell?. What is special with gnome-shell?

Note: There are some success stories around... Nothing worked for me. I tried removing fglrx, installing the 11.11 driver downloaded from AMD, disabling tear effect in catalyst control center (with and without administrative privileges), disabling VSync in compize setting ......

Note 2: I've installed Ubuntu 11.10 amd64 on Dell Inspiron N5010. Graphic card is ATI HD mobility radeon 5470.

share|improve this question
2  
I am having the same problems. I have resigned myself, since Maverick 10.10, with the idea that my next video card will be an Nvidia. :) –  bioShark Dec 12 '11 at 20:28

2 Answers 2

I can't be too technical about why this appens in gnome-shell, but I can propose a solution that in my case dramatically improved performance. I am using Gnome-Shell 3.2.1 and AMD Catalyst 11.12.

Open /etc/environment as root user by typing on a terminal:

sudo gedit /etc/environment

Add this line at the bottom of the file:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Save, and restart session.

Note, this worked for me also on a Nvidia ION platform, and is known to improve graphics on Intel as well.

share|improve this answer

You may need to adjust your vlc settings!

My setup:

  • XFX Radeon HD 6670
  • Catalyst 11.12
  • gnome-shell 3.2.1-0ubuntu1
  • vlc 1.1.12-2~oneiric1

Settings to change:

You'll need to open up your vlc preferences (Tools -> Preferences) and change some settings under a few categories.

Interface:

  • Uncheck Show systray icon
  • Uncheck Systray popup when minimized

Video:

  • Uncheck Accelerated video output (Overlay)

Save your settings, restart vlc.

Why change these particular settings?

According to GNOME's guidelines, using systray icons in the notification area is deprecated. I also noticed a lot less screen flicker when starting up vlc with the systray options turned off.

After that I still had problems, but only when first opening a video file and closing vlc with a video currently playing.

After disabling accelerated video, I was expecting video playback to be worse. However, video files played better than before, more smoothly. I could especially notice it when watching full screen video.

There might be other applications that still trigger the driver's instabilities, but these adjustments to vlc fixed the problem for me!

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.