Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Suddenly, I am not able to use any combination of meta keys. The Alt key is not working at all in my emacs. Can anyone help me on this issue?

share|improve this question
    
A quick workaround is that hitting escape before another key acts as Meta+key_you_pressed. It's better to figure out what's causing the problem but hopefully this helps for the time being. – Dason Dec 12 '11 at 18:41
    
@Dason Thanks for the comment. It works, but only once. I have to hit escape every time before any Meta command. Weird. I wish I can find what is causing this. – NeoJi Dec 12 '11 at 18:54
4  
Could it be that the terminal window is capturing <key>Alt</key> and attempting to use it to access it's menus (eg: File, Edit, etc..) – drevicko Mar 2 '12 at 4:16
up vote 2 down vote accepted

I fixed this in my Ubuntu Terminal app by going in the menu: Edit -> Keyboard Shortcuts and deselecting the 'Enable menu access keys (such as Alt+F to open the File menu)'.

share|improve this answer

My VNC server had to be restarted with an extra option -compatiblekbd like this example:

vncserver -geometry 2549x1476 :17 -compatiblekbd

Once I added that and restarted my server, the meta key started working as I expect it to.

Note that -compatiblekbd must come after the display number (e.g. :17) or it is interpreted as an argument to -compatiblekbd.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.