Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my ubuntu 10.10 after configure an external CRT on S-Video in cloning desktop, I've lost my desktop icon and right clicking on it does not show menu and menu bar too.

I've tried to resolve with following command:

sudo apt-get install ubuntu-desktop
sudo apt-get install gnome-panel
sudo chown -R $ USER: $ USER /Scrivania

with following sequence of commands I've gotten again main menu but nothing to do for get back my desktop:

mkdir ~/.oldpanel
mv ~/.gconf/apps/panel ~/.oldpanel
gconftool-2 --shutdown
pkill gnome-panel
sudo apt-get install --reinstall ubuntu-desktop

Have you any idea to resolve my problem?

I've also posted this question on: http://unix.stackexchange.com/questions/3328/ubuntu-desktop-lost

thanks in advance ciao h.

share|improve this question
1  
What do you mean with 'lost'? Also, reinstalling ubuntu-desktop won't do you any good, it's just a meta package which does nothing. You might want to reinstall the complete gnome environment: sudo apt-get install --reinstall gdm nautilus gnome-panel. Make also sure that you have selected Gnome as session during login. –  Bobby Oct 21 '10 at 19:48
1  
Thanks for answering, for 'lost' I mean that I have lost my icons on desktop I can see and reach them only clicking on menu Places->desktop, If you want I can upload my empty desktop but I do not think that it will be useful. –  haltman Oct 21 '10 at 22:25
    
@haltman Ah, that will be useful then, please add this information to your question so that it doesn't get lost in the comments. –  Jorge Castro Oct 21 '10 at 22:42
    
@haltman So there is no wallpaper either? –  Alvin Row Oct 21 '10 at 22:42
    
@DoR No i can see wallpaper but is empty and I can't save on it; may work reinstall complete gnome environment like Bobby suggested? thanks. –  haltman Oct 21 '10 at 22:51

5 Answers 5

This is the same answer I gave on the Unix & Linux Stackexchange. Reposting it here, so the question doesn't show up as unanswered:

Since the application responsible for drawing the desktop, is nautilus not gnome-panel, you might have more luck by looking at nautilus' settings.

Specifically, if the gconf-key apps/nautilus/preferences/show_desktop is set to false, nautilus won't show any desktop icons. So if the key is set to false, you should change it to true.

If that's not the case, you might try to backup and delete your nautilus settings same way you did with your gnome-panel settings.

share|improve this answer
    
I cannot find this gkonf-key on my file, I have to add it? –  haltman Oct 25 '10 at 16:25
    
@haltman: Since the default value for that key is true, I would think that it not being there is the same as it being true. However there's no harm in explicitly setting it to true anyway. –  sepp2k Oct 25 '10 at 16:38

I just did a update from Lucid to Maverick and I'm seeing the exact same problem (with all users on my system). I followed just about every resolution step I could find (including removing all my settings via

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

reinstalling ubuntu-desktop, confirming nautilus' show_desktop setting is clicked, etc. Still, no desktop icons (even though they are there when I go to Places-->Desktop).

share|improve this answer
    
Finally found a solution. It turned out to be some problem related to compiz. Don't ask we why, I never mess with compiz. Anyway after removing all compiz related packages using synaptic, everything returned to normal –  Frank W. Dec 13 '10 at 14:35
    
That's a great think! I've to try it! –  haltman Dec 14 '10 at 14:14
    
Thank you sooooo much for the delete all COMPIZ packages solution!!! I was just about to freak out figuring out this problem for half a day!!! You really made my day, Frank W.!! –  user10764 Feb 13 '11 at 17:27

Maybe wrong folder is set as Desktop folder. Go to your home folder and then into .config folder (it's hidden, press ctrl + h to see it).

Open user-dirs.dirs with gedit and check the line starting with "XDG_DESKTOP_DIR", in your case maybe you have to change "XDG_DESKTOP_DIR="$HOME/Desktop" into "XDG_DESKTOP_DIR="$HOME/Scrivania" if Scrivania is the folder the you want to use as desktop. Hope it helps.

share|improve this answer
    
Thanks for answering my home folder is already configured in this way –  haltman Oct 25 '10 at 16:23

If you have Ubuntu Tweak installed then go to

Applications > System Tools > Ubuntu Tweak

Now click on Desktop Icon Setting under the title Desktop from the left side and check box Show Desktop Icons

I think this should work.

share|improve this answer
    
Thanks for answering but I already have this voice selected. –  haltman Oct 24 '10 at 12:25

I had this same issue when upgrading to Saucy--13.10. I tried many CLI solutions listed in many places, all to no avail. based on suggestions above, however, I did the following and it worked!

  1. In the Dash, search for dconf Editor and open.
  2. On the left hand side of the page are 'menu' items, select the triangle next to 'org' to open that up.
  3. Then open 'org', then 'gnome', then 'desktop' and finally click on 'background'.
  4. the properties or elements of this option are shown in the box. For all the users in this system I had to click on the checkbox, "show-desktop-icons", solving the original issue asked above. For one of my users I also had to put a check in the "draw-background" box as well since her desktop background wasn't showing as well.

Good luck future travelers to this page!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.