Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 on VirtualBox with the following specs:

  • 1024 MB RAM
  • 128 VGA
  • 16 HDD

Then I tried to install GNOME Shell as in this OMG! Ubuntu post.

But I didn't get the same result. The shell seemed to be so basic; I didn't get hot corners, for example.

enter image description here

share|improve this question
Have you ticked "3D acceleration" on the virtual machine settings? Please dropbox (or something similar) a screenshot of your issue. – fossfreedom Dec 12 '11 at 10:48
this is what i got : – Mohammed Atef Dec 12 '11 at 12:09

Your screenshot indicates that Gnome-Shell refused to load and has dropped back to the default fallback mode called Gnome-Classic.

Three specific virtualbox recommendations:

  • I would recommend that you define your VirtualBox guest settings as per this picture:

    enter image description here

  • Install VirtualBox guest additions

  • I would recommend you use the very latest VirtualBox version - v4.1 at the time of writing this.

Note - it is important to check that your Host graphics card is 3D Graphics capable - This is described in this linked VirtualBox chapter

share|improve this answer

Your screenshot shows Gnome Panel, which is the shell we've used in earlier versions of Ubuntu and that has been Gnomes primary shells for more than a decade. Gnome Shell is very dependent on hardware and good drivers. They're working on a version that is less hardware dependent. It might be easier to recognize by these images (it's the same desktop):

Showing a customized gnome-panel desktop.

One thing to notice is that the way you add applets and things like that has changed. You now hold super+alt and right click to show the menu in the first screenshot. You use alt+middleclick to move applets around.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.