Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The best way to describe what is happening with words is to think of a video where if I grabbed my nautilus window and moved it from one side of the screen to the other. Now think of that video and I removed lots of frames in the processes so the window basically starts where I grabbed in and everything in between is lost.

I have a stock install with the Nvidia drivers that got installed during the graphical installer. I had the issue so then I installed the "Post-Release-Updates" and the problem still isn't fixed.

Lovin unity, but I haven't been able to use it since 10.xx

Any ideas?

THIS IS THE LOG AFTER INSTALLING FROM NVIDIA SITE New xorg.log

http://pastebin.com/L2jrJCey

share|improve this question
    
Try installing the nvidia drivers from nvidia homepage. This works fine for me.However, each time you change kernel version you have to reinstall it again :( –  Michael K Dec 12 '11 at 6:19
    
Thanks for the comment. Where you using the same Video card? Or did you just have the same issue. –  Goddard Dec 12 '11 at 7:51
    
Neither nor, I just never had problems with the nvidia driver installed this way.I have a GTS250.However, they all use the same driver and GTX460M should work as it is not a rarely used graphics adapter. –  Michael K Dec 12 '11 at 7:57
    
I installed the newest version using the x-swat ppa. That is version 290.* and it still lags. Any optimization advice? –  Goddard Dec 12 '11 at 20:33
    
I opened a bug report bugs.launchpad.net/unity/+bug/903395 –  Goddard Dec 12 '11 at 21:21

2 Answers 2

up vote 2 down vote accepted

I have found out the problem is my mouse oddly enough.

I have an ASUS Republic of Gamers mouse which is probably made by Logitech or uses the same guts. Supposedly these mouses are the issue. Not sure on the actual fix, but I unplugged the sucker and restarted and all is well, but now I have no mouse besides this track pad...

share|improve this answer

It is not a bug, only a misconfiguration:

[ 11.389] (EE) Failed to load module "nv" (module does not exist, 0)
[ 11.389] (II) Module vesa: vendor="X.Org Foundation"

From those two entries you can see that the NVidia driver is not loaded, instead the vesa driver is loaded. You wont have performance that way, especially not with unity.Can you have a look whether /etc/X11/xorg.conf exists and search for a section "Device" and in this section for the entry "Driver" . There you will find:

Driver "nv"

Replace this by:

Driver "nvidia"

And still the suggestion: Use the driver directly from Nvidia!!!!!!!!! The driver installation also takes care for setting up your X-Server correctly which seems to be not correct in your case.

share|improve this answer
    
I installed the nvidia drivers from the site. Still same problem unfortunately. Here is my xorg.log please see if there is any more errors I need to fix. pastebin.com/L2jrJCey –  Goddard Dec 14 '11 at 6:57
    
Do you have the /etc/X11/xorg.conf file? If yes, please also add this file. The xorg.log I also had, the two lines are from this file, which I found in your bug report (which I also marked as invalid, as the two lines show a misconfiguration of your system). More information is necessary to help you out there. –  Michael K Dec 14 '11 at 8:14
    
Here is a link to the xorg.conf file pastebin.com/eb5dA6W0 –  Goddard Dec 14 '11 at 9:02
    
Ah its a new log file now, sorry :-D - now the driver seems to load correctly. Next step is to check OpenGL support. What does 'glxinfo | grep rendering' output? Does glxgears work? –  Michael K Dec 14 '11 at 9:10
    
Here is that output : direct rendering: Yes GL_NV_parameter_buffer_object2, GL_NV_path_rendering, –  Goddard Dec 14 '11 at 9:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.