Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got Ubuntu 11.10 64bit setup on my system that's a got a ATI Crossfire setup (I already installed the proprietary ATI drivers and Catalyst with no issues) however I don't seem to be able to control the second video cards fan speed that seems to be running at max (I have lm-sensors & fancontrol setup).

# aticonfig --pplib-cmd 'set fanspeed 1 31'
PPLIB command execution has failed!
ati_pplib_cmd: execute "set" failed!

Works just fine on the first card:

# aticonfig --pplib-cmd 'set fanspeed 0 31'
PPLIB command execution is Successful!

Both cards are being detected as you can see here:

CrossFire chain for adapter 0, status: enabled
  0. 0f:00.0 ATI Radeon HD 5900 Series
  1. 0e:00.0 ATI Radeon HD 5900 Series

Some help please.

share|improve this question
add comment

1 Answer

Take a look at this AMD GPU Coolness page:

the assumption that aticonfig --pplib-cmd "set fanspeed 1 85" will set the fan on the second GPU is incorrect. This would set a - hypothetical second fan on the same GPU. Rather the selection of GPUs has to be done via the DISPLAY environment variable, where a display of :0.0 would refer to the first configured GPU, and :0.1 to the second and so on.

You may want to try the following to set the second display card fan speed:

DISPLAY=0.1 aticonfig --pplib-cmd 'set fanspeed 0 31'
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.