Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Evolution email client on Kubuntu 11.10 and it's not so cute as expected.

enter image description here

Eclipse also looks bad. I have the GTK+ Appearance plugin in KDE System Settings and already tried QTCurve and Oxygen option, no help. When the GTK+ skin was working, this appearance still showed when I ran an application as root.

Tried:

sudo apt-get install oxygen-molecule gtk2-engines-oxygen

There is a problem with KDE/GTK relation. How can I solve it?

share|improve this question

6 Answers 6

Make sure you have the following packages installed (they should have been installed by kubuntu-desktop, but may have gotten missed):

sudo apt-get install gtk2-engines-oxygen kde-config-gtk

Then go to the KDE Control centre and make sure that the checkbox for using KDE themes in GTK apps is checked.

share|improve this answer

Evolution probably uses GTK3 while the instructions are valid only for GTK2.

I'm not sure what is the policy of AskUbuntu on external links, but this one provides a solution for GTK3:

http://maketecheasier.com/make-gtk3-apps-look-presentable-in-kde4/2012/01/04

share|improve this answer
1  
It is preferable to include the essential parts of the answer here, and provide the link for reference. –  jokerdino Feb 11 '12 at 11:32
    
Fixed it for me! Fwiw, the command is sudo apt-get install gtk3-engines-oxygen. –  Björn Lindqvist Feb 23 at 0:48

Here is the latest gtk config tool that allows easy customization of GTK2 + GTK3 under KDE:

http://www.netrunner-os.com/gtk2-gtk3-configuration-under-kde/

It will likely become official tool in next KDE version.

share|improve this answer
up vote 1 down vote accepted

I accidentally found the right answer here

share|improve this answer
    
It is preferable to include the essential parts of the answer here, and provide the link for reference. –  gertvdijk May 27 '13 at 20:00

Not a solution, but a work around. Try setting your appearance with lxappearance

sudo apt-get install lxappearance

It (lxappearance) should be in your KDE menu, under settings, or run it manually with lxappearance.

lxappearance seems to work better then kde-config-gtk for some people

Another potential problem is running applications as root.

sudo cp /root/.gtkrc-2.0 /root/.gtkrc-2.0.backup
sudo cp /root/.gtkrc-2.0-kde4 /root/.gtkrc-2.0

You can un-do that command if needed (you might break gksu or running applications as root under gnome or other DE, may not be an issue if you only run KDE)

share|improve this answer
    
Eclipse is fixed now, but Evolution not. –  piovisqui Dec 12 '11 at 0:58
    
One out of 2 is not bad =) , sorry you are having problems. –  bodhi.zazen Dec 12 '11 at 1:01

KDE uses the "system" font hinting as default (where is this system hinting config located?), and GTK not.

So, make KDE uses the QT configuration, which will force GTK to use the same.

On KDE Settings, Application Appearence, Fonts, I selected "Use anti-aliasing" as "Enabled", opened "Configure", than unchecked "exclude range", checked "use subpixel", and select "slight" for "hinting style". This will force gtk to use the same font hinting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.