Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Coming from a Mac, the standard modifier keys on Linux (and Windows) are pretty irritating.

  • I need my thumb to be able to hit control so I need to change alt to control.
  • I need the windows key out of the way so I need to change control to windows.
  • I need alt in the middle so I need windows to become alt.

I've tried to do this via the Keyboard Layout control panel but it doesn't seem to offer the right combination of options. I've also tried via xmodmap but it seems even adding one keysym breaks my return and escape keys for no reason known to me. I've searched around here but the only answers I can find involve swapping two keys rather than moving three around.

Any help would be much appreciated.

share|improve this question
    
Just to confirm - the English (macintosh) keyboard layout does not do what you want? –  grahammechanical Dec 12 '11 at 15:57
    
No it does not. –  Sikora Dec 12 '11 at 18:18
    
To clarify, I'm not using an Apple keyboard. I merely want to move some keys around on the standard PC keyboard I have. –  Sikora Dec 12 '11 at 18:23
    
You could always rearrange your hand... –  Brian Graham Dec 12 '11 at 19:02
1  
@Sikora Welcome to Ask Ubuntu! If you solved your problem yourself, please post instructions as a new answer and not as an edit to your question. Thanks! –  htorque Jan 3 '12 at 10:06

2 Answers 2

Install Compiz Config Settings Manager

sudo apt-get install compizconfig-settings-manager

Open Compiz Config Settings Manager and go to Preferences

enter image description here

Under unity you can set your keyboard bindings.

See this forums post for details

share|improve this answer
    
Unfortunately this isn't what I want. I do want to literally remap the keys globally. For example, I want Super_L to continue to bring up the dash; I just want to change which key is Super_L. Normally I'd think I'd be able to do this with xmodmap, but it seems that any attempt to do so ends up breaking escape, return, and other keys. I'm not sure if this is an Ubuntu-specific problem. –  Sikora Dec 12 '11 at 2:15

The OP answered the question and posted the solution in the question.

I ended up solving this problem by remapping Windows to Control and Caps Lock to Hyper in Keyboard Layout. I then used CCSM to remap the Unity dash key to Hyper. I also remapped things like Alt-Tab to Control-Tab (which is now physically Windows-Tab if you're still following) to get a more Mac-like experience. I no longer have a Windows key but after the CCSM remapping I have no use for one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.