Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I switched to Gnome Shell on my 11.10 install. One annoyance is that whenever I insert a removable drive, nautilus opens the drive and at the same time gnome shell displays its popup. I discovered that killing the "gnome-fallback-mount-helper" process solves the issue. My question is: how can I kill the process at startup or better yet stop it from ever starting. Thank you in advance!

share|improve this question
add comment

3 Answers

Run gnome-session-properties and either disable gnome-fallback-mount-helper or if that is not an option, add a custom command.

share|improve this answer
add comment

In system configuration you can setup nautilus behaviour for every time you plug a removable drive. Look for it, I don't know the name in english; in spanish the app is called "Soportes extraíbles".

Hope it helps.

share|improve this answer
add comment

You can prevent nautilus from opening the drive automatically and just use gnome-shell's function for the media handling. To do this open gnome-control-center from a terminal and search for 'Removable media' option in the dialog. There are all available option for removable media (cd, dvd ... etc) in that window. For example to prevent nautilus from doing anything when a CD disk is inserted just choose the appropriate option "Do nothing"...

enter image description here

In the same way you can choose the option for various media types.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.