Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have read several questions regarding how to fix an already enabled desktop cube or the problems it had in 11.04. But in 11.10, how can I correctly enable desktop cube in Unity 3D?

share|improve this question

2 Answers 2

up vote 26 down vote accepted

This is what I invented and tested with more than 20 PCs. Note that you actually NEED a video card that can render this and to have the drivers correctly installed. Look for the answer in the following links to install the drivers correctly:

How to Install Nvidia Drivers

How can I update my NVIDIA driver?

Can not install Nvidia driver

What's the difference between the nvidia-current, and nvidia-current-updates packages?

  1. Install Compiz Config Settings Manager

    (Note: What are some of the issues with ccsm and why would I want to avoid it?)

    sudo apt-get install compizconfig-settings-manager
    

    NOTE: If you have 12.10 or above you need to also install the compiz-plugin package. So instead of the final terminal line mentioned above, it would be:

    sudo apt-get install compizconfig-settings-manager compiz-plugins compiz-plugins-extra
    

    If you do not install the compiz-plugins you will not see the cube or rotate plugins in the compiz plugin list.

  2. Open Compiz Config Settings Manager and go to Preferences

    Open CCSM from dash

    Preferences

  3. Select Plugin List Tab

    Plugin list

  4. Disable Automatic Plugin Sorting and accept the warning that will appear after trying to disable it.

  5. From the Disable Plugins List, Enable the following plugins: cube, rotate

  6. From the Enable Plugins List, Disable the following plugins: wall

  7. Go back from the Preferences menu to the Main Compiz Menu and select General Options

    General options

  8. Go to Desktop Size tab and change the Horizontal and Vertical Virtual Size to 4:

    How it looks in 12.04 or below Virtual Desktop Sizes in 12.04 How it looks in 12.10+ Virtual Desktop Sizes in 12.10+

DONE

There is no need to restart the PC or logout or anything additional to this steps. In this case it works on Nvidia, Ati and Intel cards.

If you want to add more Effects you would do them in the Preference options but you need to be careful which Plugins have problems with others. In this case they are working excellent.

HOW TO TEST IF IT IS WORKING?

Simply leave CTRL+ALT pressed and then with the Arrow keys press -> or <- to rotate Right or Left, respectively.

You can also (If you mouse has support for a third middle button), leave the middle button pressed while in the desktop (Without selecting anything else) and move your mouse around.

I will need to test it even further to say that it is stable but so far am typing this with the Cube effect activated, could drag a video I was watching to another virtual desktop and no problems.

On 12.04 watching Family Guy

Desktop cube

On 12.10 watching Game of Throne + AskUbuntu

enter image description here

On 13.04 watching (actually crying) Fringe:

enter image description here

Lastly, you can just download My Compiz Profile to import using the CCSM Import option and have the configuration that is mentioned in this post.

HOW TO GO BACK TO DEFAULT?

If this is giving you any video errors or glitches, then you need to go back to the defaults. I would try to run ccsm again and simply put the "Wall" plugin back from Disabled to Enabled in the Preferences Menu and then Activate the "Automatic Plugin Sorting". Or just set all plugins to automatic by enabling the Automatic Plugin Sorting option again. Now logout/login just in case any of them gives an error or weird behavior. If you can't open the Compiz Settings Manager go to the terminal and type ccsm.

Options to reset Compiz and/or Unity to default (In case of an error) are:

UPDATE - Confirmed working on at least 10 PCs and 5 Laptops. All laptops are HP ranging from DV6000 up to DV9700. The desktop PCs are all Intel Core 2 Duo and all have Nvidia cards. The laptops only the last 2 have nvidia cards. The rest are intel.

share|improve this answer
1  
Amazing answer + Family Guy, why aren't you mayor?! –  MasterMastic May 1 at 10:34
  1. Install compizconfig-settings-manager

    sudo apt-get install compizconfig-settings-manager
    
  2. Run ccsm, see these screenshots

    Screenshot 1

    Screenshot 2

  3. Log out and back in.

  4. If that fails, try "resetting" your compiz settings

    rm -rf .gconf/apps/compiz*
    rm -rf .cache/compizconfig-1/
    rm -rf .config/compiz-1/
    rm -rf .compiz*
    

    Log out and repeat the above steps.

    Rotate

Source : http://ubuntuguide.net/enable-compiz-desktop-cube-in-ubuntu-11-10-oneiric-unity

share|improve this answer
    
Bodhi that is the same as Naruto mentioned and not worked. At least for me. Leave it here as a answer just in case it works for other people. –  Luis Dec 11 '11 at 21:19
    
Ouch, must have been posting at the same time , sorry. Did you try deleting your old settings ? –  bodhi.zazen Dec 11 '11 at 21:22
    
Yeah of course. I followed the guide step by step. Deleting the settings made a reset for me which solved the problems that appeared after setting the cube effect. It went crazy the second I activated the option. Using the way I did it at least I have tested on 3 PCs and until now no weird problems. I ask to leave your answer here since it might work for other users and mine might not. This is why I need to test a little further. Maybe 4 or 5 laptops and 8 PCs should do it. –  Luis Dec 11 '11 at 21:27
    
Alright, sorry you are having a problem. Fell free to mark my answer for deletion pending further attempts / testing. –  bodhi.zazen Dec 11 '11 at 21:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.