Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I boot into Ubuntu, as soon as I login, I get a dialogue window pop up that says Couldn't find "/media/[long string here]". Please check the spelling and try again."

Upon looking at my /etc/fstab file I found out that long string is actually the UUID of the root partition.

I also found out that exactly the same thing happens if I do nautilus -q in the terminal. I then created a folder /media/<long string here>. Now, instead of getting that error dialogue box, a regular nautilus window opens at that folder (on both situations described above).

It is clear that whenever the nautilus process starts (which happens on login and on nautilus -q) it tries to access that folder instead of starting quietly. What's going on here, and how can I fix this? It doesn't really break anything else, it's just annoying.

EDIT:
Here is the output of ls -al /dev/disk/by-uuid/

drwxr-xr-x 2 root root 180 2010-10-21 10:02 .
drwxr-xr-x 6 root root 120 2010-10-21 08:02 ..
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 221643331643076F -> ../../sda1
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 34e5211a-ad8f-4ffe-b3f8-b70b767fd993 -> ../../sda5
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 4b41a6d6-0a8b-4ece-a7c4-712901fbf7b0 -> ../../sda8
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 7c1303c4-02c0-4970-b653-1c6bd78938fa -> ../../sda6
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 9480DE4180DE2A0E -> ../../sda2
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 c8c3aef2-360d-4fbc-ac31-a4e4dc57c110 -> ../../dm-0
lrwxrwxrwx 1 root root  10 2010-10-21 10:02 e08c11e3-1c5c-474c-a9d6-b7e7ba095fa7 -> ../../sda7

The fifth line of this output contains the UUID that nautilus keeps trying to open. /dev/sda8/ is my root partition.
Here is the output of /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/mapper/home   /home           ext3     defaults    1       2
# / was on /dev/sda8 during installation, with UUID=4b41a6d6-0a8b-4ece-a7c4-712901fbf7b0.
/dev/sda8        /               ext4    errors=remount-ro 0       1
/dev/sda6       none            swap    sw              0       0

As you can see I've got an encrypted home partition, a swap, and a root partition on the fstab file. Again, that UUID on the tenth line is the one nautilus keeps trying to open as /media/<UUID>.

Here's the error message I get, for reference: Error message.

share|improve this question
2  
The long UID is probably something like a USB key or some other removable media. Do you have anything like that bookmarked in your places in the side pane of nautilus? For some reason nautilus is trying to access a removable device. –  Richard Holloway Oct 21 '10 at 15:46
    
@Richard Holloway: According to fstab, the long UID is the UID of the root partition. Is there a command I can use to check UIDs? All my bookmarks are regular folders inside my home folder and the home foldr itself. –  Bruce Connor Oct 21 '10 at 16:50
    
pasting the contents of /etc/fstab would be mighty helpful here, as well as the output of 'ls -al /dev/disk/by-uuid/ –  nathwill Oct 21 '10 at 17:32
2  
This sounds like something is stuck in your session-start. You could try to clear all automatically starting programs from your session by opening System -> Preferences -> Startup Applications -> Options, close everything, then hit Remember Currently Running Application and logout and in again and see if it is gone. –  Bobby Oct 21 '10 at 20:17
1  
i agree... there's nothing in fstab that would have it trying to mount the disk from /media.... the /dev/disk/by-uuid output shows that the UUID definitely belongs to sda8 which is your root partition according to fstab, but nothing in fstab is looking for anything in /media, so it's gotta be a bookmark in nautilus or a script from somewhere else... good luck, let us know if bobby's suggestion doesn't do it for ya. –  nathwill Oct 21 '10 at 21:40

1 Answer 1

up vote 1 down vote accepted

Turns out it's an issue with the startup applications. I am almost certain it was caused by copying my configs from my previous (lucid) instalation to this new one (maverick). Following Bobby's suggestion, here's what I did.

  1. Open System -> Preferences -> Startup Applications -> Options
  2. Close any currently running applications.
  3. Hit Remember Currently Running Applications.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.