Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed 11.10 on my laptop.HDDwas 160gb partioned 100gb as ext3 amd 20gb for swap.Have xp sp3 home on same drive.Installation went ok but now I do not have option to boot to dif

share|improve this question

closed as not a real question by Jorge Castro, htorque, Octavian Damiean, Takkat, Bruno Pereira Feb 4 '12 at 0:45

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you click edit and complete your question? –  Jorge Castro Dec 11 '11 at 15:52
1  
You do not need 20GB for swap. 2GB should be enough depending on the amount of memory (RAM). What install options did you chose? Use Entire Disk? Install Alongside? Do Something Else? –  grahammechanical Dec 11 '11 at 18:24

2 Answers 2

As I understand, you're not able to boot your Windows OS and it only boots into Ubuntu. I suppose that Grub2 wasn't installed within your Ubuntu 11.10 installation To install and load the grub items, just write these in your terminal.

sudo apt-get install grub2
sudo update-grub

the second line should output bootable partitions found (and you windows xp partition should also be there)

share|improve this answer

Use Following Commands

grub>find /boot/grub/core.img ( this command will gives values of x and y)
grub>root (hdx,y) (use x and y values in previous command)
grub>kernel /boot/grub/core.img
grub>boot

After the boot command you will go into grub 2 menu. Select to boot up ubuntu, and run this command to restore grub.

sudo grub-install /dev/sda
share|improve this answer
1  
improve formatting please, and promoting your blog isn't that helpfull in an answer, that belongs on your profile. –  Alvar Dec 11 '11 at 17:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.