Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do you disable the automatic activation of Gnome Shell activities button

Instead of hovering mouse hover 'Activities' (top-left corner) I want only mouse click on it to open the 'Activities' Menu .

Thanks.

share|improve this question

marked as duplicate by Jorge Castro, jokerdino, jrg, Marco Ceppi Jan 24 '12 at 15:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 4 down vote accepted

The gnome-shell Activities corner hot-spot can disabled by installing an extesnion called "No Topleft Hot Corner." Go to https://extensions.gnome.org/extensi...ft-hot-corner/. To install it, you just click "on" at the top of the page next to the name of the extension.

An earlier answer states that this can be accomplished "by editing some code - fortunately this doesnt need recompilation...

To do this:

gksudo gedit /usr/share/gnome-shell/js/ui/panel.js

Scroll down to this section in the file and comment out the line highlighted i.e. put //your_initials in fron t of this._hotCorner...:

enter image description here

Save, logout and login."

share|improve this answer
    
should I comment this._hotCorner = new Layout.HotCorner(); line and the line below it i.e container.add_actor(this._hotCorner.actor); –  Mr Coder Dec 12 '11 at 7:07
    
In my testing, commenting out just this line in the screen shot disabled the hotcorner activation. The reason why I didnt want to comment out "...new Layout" because you will have an unallocated variable - this may/probably will cause issues/crashes for any related code in that file that attempts to use that variable. –  fossfreedom Dec 12 '11 at 9:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.