Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have created an RSS feed lens based on unity-lens-python, but I cannot get the filters to work. I've also tried the original unity-lens-python and the filter does not work in that lens either.

My lens can be found on my Google documents page, and it would be great if someone could have a look into it.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Make sure you connect to the "filters-changed" signal and update your results when it's fired. For an example see the one-hundred-scopes project where this is used. ( http://bazaar.launchpad.net/~davidc3/onehundredscopes/desura/view/head:/src/unity-scope-desura#L34 )

share|improve this answer
Thank you so much. I've been struggling with this for days. This solved my problem. –  Stefan Berg Dec 22 '11 at 18:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.