Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I set my eth card to 100 Mb/s?

sudo ethtool eth0

Settings for eth0:

Supported ports: [ MII ]

Supported link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full

1000baseT/Full

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full

1000baseT/Full

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Link partner advertised link modes: Not reported

Link partner advertised pause frame use: No

Link partner advertised auto-negotiation: No

Speed: 10Mb/s

Duplex: Full

Port: MII

PHYAD: 1

Transceiver: external

Auto-negotiation: on

Supports Wake-on: g

Wake-on: d

Link detected: yes

share|improve this question

3 Answers 3

Unless you've done something inside Ubuntu to somehow limit it to 10Mbps, you can't. By default it will connect as fast as the card and the network will allow.

So either the card is only rated for 10Mbps (unlikely) or the network (be that the hub, switch, router, or whatever you're plugged into) is limiting you.

If you think I'm wrong (and I am occasionally), edit your question to let us know what hardware we're talking about.

share|improve this answer

Your ethernet device supports 1000baseT but syncs at 10baseT. There can be 3 reasons why this happens:

  1. you are connected to a device (router, hub, switch, other PC) that only supports 10baseT
  2. there is a problem with the network cable that causes too many errors when using higher speeds
  3. there is a bug in the driver for your ethernet device

I personally have a similar problem caused by reason 3 for an Intel integrated NIC that uses the e1000e driver (it autonegotiates at 100 Mbit/s while being connected to a gigabit switch).

share|improve this answer

From your ETH0 information you posted:

Link partner advertised auto-negotiation: No

whatever you are connecting to does NOT have auto-negotiation turned on or doesn't support it.

If there is no auto-negotiation enabled on BOTH ends of the ethernet connection then BOTH endpoints will revert to 10 Mbps as the default

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.