Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello, world.

My computer turned off while banshee was updating my music library. Now I can't open it. The error says: "found a fatal error. Exception has been thrown by the target of an invocation."

Any clues?

share|improve this question
up vote 2 down vote accepted

Try removing ~/.config/banshee-1/banshee.db (~ means your home folder).
If you don't see the .config folder inside your home folder, press CTRL+H to make hidden files visible, and press CTRL+H again to make them invisible again when you're done.

~/.config/banshee-1/banshee.db is the SQLite database where Banshee stores your music library. When you remove it it will be created again when you start Banshee.


share|improve this answer
Thanks, RobinJ. That worked just fine. – estebanknobl Dec 10 '11 at 15:03

I'm not sure if this will help, but you could try deleting the local configuration files for Banshee and trying again.

Open Nautilus and press CTRL+H to show hidden files and folders. Browse to the folder .local and inside you will find a folder called share. Open this folder and find the folder called banshee and delete it. Then try reopening Banshee.

If that doesn't work you can try reinstalling the application by using the following terminal commands.

sudo apt-get remove banshee
sudo apt-get update
sudo apt-get install banshee

Again, I'm not sure if this will help or not, but I'll add that if you try opening Banshee from the Terminal it should spit out an error report. If you post that here in your question, perhaps someone who knows more than me can help you.

share|improve this answer
Don't forget to make a backup of ~/.local/share/banshee before you try the steps @shawn mentioned. You can also try to run these commands without deleting ~/.local/share/banshee sudo apt-get remove banshee sudo apt-get update sudo apt-get install banshee If that doesn't work out, you can try Shawns solution. – Robert Kresse Dec 10 '11 at 14:32
Thanks, Shawn. The answer provided by RobinJ worked fine. – estebanknobl Dec 10 '11 at 15:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.