Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm sure that this has been asked before. I'm not completely new to Ubuntu, I started with 9.04, but I stopped using it for a long time, and am currently Dual-Booting 11.10 alongside Windows 7 on my laptop.

I wanted to enable the Compiz effects, but Ubuntu was not recognizing my graphics card (nVidia GeForce 525M) so I thought maybe updating the driver would help. I Ctrl+Alt+F1 entered TTY mode, and I did the following:

sudo service lightdm stop
cd ~/Downloads
sudo sh ./NVIDIA-Linux-x86_64-290.10.run

and then I went through the setup for the nVidia driver. It said it installed correctly, so I restarted my laptop through Ctrl+Alt+Delete, and then when I went to load Ubuntu, it loaded in TTY mode.

I can't seem to figure out how to get back to the User Interface for Ubuntu.

Anyone who could help me out, it would be greatly appreciated.

share|improve this question
    
Log in as your user, then try running sudo nvida-xconfig . Then sudo service lightdm start –  bodhi.zazen Dec 10 '11 at 1:05
    
Doing that brought up this screen link Which coincidentally is the screen that Ubuntu actually loads to when I choose it at the boot manager. Sorry if that is misleading from my original post –  Matt Miller Dec 10 '11 at 1:25
    
Bad news - According to the Nvidia Linux Forums, there is no support for your card in Linux. nvnews.net/vbulletin/showthread.php?t=161471 I did not find any solution and I can not test your hardware. If the nouveau driver (the default driver) does not work you can file a bug against it in Launchpad. You can try filing a bug report with Nvidia as well. –  bodhi.zazen Dec 10 '11 at 5:51
    
Oh, great. That sucks. I'll just have to reinstall Ubuntu to fix my TTY issue then. Thanks for checking that. I appreciate it. –  Matt Miller Dec 10 '11 at 17:53
add comment

closed as off topic by jrg May 23 '12 at 17:14

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

The same thing happened to me and I had to reinstall Ubuntu :( I don't know why it does it but I think the only thing you can do is reinstall. However someone correct me if I'm wrong

share|improve this answer
    
I installed Ubuntu through Windows 7 using Wubi just as a precursor, because I had a feeling something would happen lol. I did it mostly for last resort. I will wait and see if anyone else has a way to fix it, and then leave unistall/reinstall to the end. Did you also have issues with the wireless not working? Mine fails to turn on, when I go into the settings, I turn wireless on, and it immediately turns itself off. I can connect through Wicd, but I cannot install any software, because Ubuntu thinks I'm not online. –  Matt Miller Dec 10 '11 at 2:24
    
I did the exact same thing and installed through Windows 7 and I do have wireless problems but only after I wake my computer up from sleeping. –  Jakehero Dec 10 '11 at 2:29
    
I've had wireless problems since I installed it. The only way to install any programs is to go wired. –  Matt Miller Dec 10 '11 at 2:50
    
if reinstalling fixed it then mark my answer as the right one that way people know it's what they have to do. –  Jakehero Dec 13 '11 at 21:19
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.