Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I updated BIOS/UEFI version to 1101 on an Asus P8Z68-V PRO motherboard Ubuntu (11.10) did not boot. After POST all I saw was a black screen with a blinking cursor in the top left corner.

I booted an Ubuntu 11.10 live-CD and set the flag for the 20 MB partition before my boot partition to "bios_grub". Then I was able to boot and login. But now every time I boot and Ubuntu loads I get the following message:

Disk drive for /boot/efi is not ready or not present.
Continue waiting or press s to skip or m for manual recovery.

I am able to login if I choose to ignore it by pressing s, but what does this message mean?
How can I fix what the message warns about?

After logging in I have noticed that /boot/efi is empty.

The following forum post speaks of the same issue

Updating to the latest BIOS/UEFI - version 3203, did not have any effect on this issue.

share|improve this question

closed as too localized by Marco Ceppi May 3 '12 at 20:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

You are still experiencing this issue then? – James Dec 20 '11 at 15:09
@jrg I still get the /boot/efi not ready message and I have to press S for it to ignore it so that I can login. Also, /boot/efi is empty. – N.N. Dec 20 '11 at 15:29
Which VGA solution do you use? If it's a dedicated GPU, does it also happen with the integrated Intel GPU? I'm using the non-Pro version of that board and have no such issues using the Intel HD Graphics. Haven't tried a dedicated GPU yet. – htorque Jan 12 '12 at 22:57
@htorque I am using the integrated graphics via DVI. Also, I am not sure if I follow why you ask me about graphics for this issue? It seems to be connected to UEFI and not graphics. – N.N. Jan 13 '12 at 8:58
Too bad. I asked this, because that's the only hardware difference - besides your board being "Pro" - that I could think of. I usually disable everything I don't need in BIOS, so I'll try to enable stuff bit by bit and see if I can reproduce this problem. Anyways, I think this should be reported as bug (against linux or grub, no idea). – htorque Jan 13 '12 at 9:12
up vote 1 down vote accepted

My suspicion is that your firmware upgrade changed the rules for whether the computer tries to boot in BIOS mode vs. EFI mode, and that your installation was such that the computer has now switched from EFI mode to BIOS mode. I'm not 100% positive of this, though; more information is required. Please post back with the output of the following commands:

sudo parted /dev/sda print
ls /sys/firmware/efi
grep efi /etc/fstab
blkid /dev/sda1

The combination of those commands' output will probably tell me what I need to know to give you a better solution. Please be sure to format them as code by indenting every line by four characters; that will help keep them legible.

share|improve this answer
I appreciate your answer but I am afraid I have made a clean install since this happened and, thus, no longer have the problem. – N.N. May 3 '12 at 20:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.