Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to know why the "popping" sounds were disabled, the ones that sound when I changed the volume, very Mac OSX like.

Is it possible to re-enable them? I'm using Ubuntu 11.10 and I loved those sounds by the way.

Regards

share|improve this question
    
Check that you have an alert sound set in Sound Preferences > Sound Effects, and that the alert volume is turned up. –  cscarney Dec 9 '11 at 19:26
    
The volume is at maximum in Preferences-> Sound Effects –  victorhqc Dec 10 '11 at 17:09

2 Answers 2

OK, it seems that in it's default configuration 11.10 with compiz doesn't ever play the system alert sound.

To fix this, open /etc/pulse/default.pa:

sudo nano /etc/pulse/default.pa

Around line 158, you should see a line that looks like:

#load-module module-x11-bell sample=bell-windowing-system

Remove the leading "#" so that it reads:

load-module module-x11-bell sample=bell-windowing-system

Save that file, log out and back in, and you should have your alert sounds back.

share|improve this answer
    
I did that but doesn't seems to help. I think an update deactivated the sounds. –  victorhqc Dec 10 '11 at 20:20
    
I tested it on an up-to-date oneiric system and it worked for me. Can you hear the alert sounds when you select them in sound preferences? –  cscarney Dec 10 '11 at 20:44
    
Yes I can, and my Ubuntu is up to date, every other notification sound seems to work properly –  victorhqc Dec 11 '11 at 19:45
    
As a note, this doesn't work in 12.10. –  Jeff Jan 25 '13 at 16:52
  1. Start nautilus with root access by opening terminal (Ctrl+Alt+T)

  2. Type sudo nautilus

  3. Type in the password. (The characters don't show. Just type it and press enter)

  4. go to /usr/share/sounds/ubuntu/stereo

  5. copy all the files in that folder and paste them at /usr/share/sounds

  6. If you have used dconf editor before to mess with the sound settings in org then return it to default value (freedesktop). If not then skip this step.

  7. Close nautilus. Exit terminal. Lougout and Login again.You will have gotten back the popping sound and also other system sounds if they were missing before. (logon sound, warning sounds, etc.)

P.S. Answer obtained from other site not particularly for this problem; however upon trying it out, it worked. Hope it helps you too.

share|improve this answer
    
Last night I received another update to the sound settings and again lost the popping sound. Tried doing again what I mentioned above. It no more worked for me. –  SagarK Dec 14 '11 at 5:52
    
It didn't work for me either, may be the popping sounds are no more by default? –  victorhqc Dec 17 '11 at 7:23
    
Surprisingly the popping sound works in gnome shell. could it be a problem with unity? –  SagarK Dec 21 '11 at 6:25
    
I've No idea, I like using unity (: –  victorhqc Dec 27 '11 at 4:30
    
Now it works again, I think an update fixed the problem, thanks for all the help (: –  victorhqc Feb 7 '12 at 6:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.