Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I switched today to the internal Intel HD graphics of my G630T CPU. The desktop works but XBMC would not start. It complains that it needs OpenGL accelerated hardware.

When I check the System Info - Graphics, there is only a generic(?) card listed:

Driver (with the space in the beginning)

Experience Standard

then I checked

lshw -C video
*-display               
   description: VGA compatible controller
   product: 2nd Generation Core Processor Family Integrated Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:42 memory:fb800000-fbbfffff memory:e0000000-efffffff ioport:ff00(size=64)

I am not sure if here is everything correct but it seems not completely wrong to me. However, glxinfo is definitively strange:

glxinfo 
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

I am running Ubuntu 11.10 3.0.0-13-generic #22-Ubuntu SMP and help is very much appreciated, as I have no clue what I could do (beginner in Linux).

Martur

share|improve this question
    
Have you removed your /etc/X11/xorg.conf file after removing the nVidia card? –  Bruno Pereira Dec 9 '11 at 18:10
    
No, should I do that? There is not much in this file: Section "Device" Identifier "Default Device" Option "NoLogo" "True" EndSection –  Martur Dec 9 '11 at 18:35
    
I renamed the file (instead of deleting it) and did a restert but that did not make any difference. –  Martur Dec 9 '11 at 18:44
    
You did not remove the nVidia driver did you? –  Bruno Pereira Dec 9 '11 at 19:03
    
No, at first I just activated the internal graphics and plugged the monitor to it. Then the NVidia drivers were still listed in the "System Settings - Additional Drivers" menu. Thereafter I removed the NVidia card from the computer and the drivers were not listed any longer. –  Martur Dec 9 '11 at 19:10

1 Answer 1

up vote 17 down vote accepted

You need to remove the nvidia drivers so that the driver does not try to get itself loaded instead of your Intel card.

Normally no further installation of drivers is required for the Intel built in driver but if the nVidia driver is getting loaded it will take over.

sudo apt-get purge nvidia*

Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

Reinstall xorg completely

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

Re-configure Xorg

sudo dpkg-reconfigure xserver-xorg

Reboot

sudo reboot
share|improve this answer
    
I removed the NVidia card and it is not available any longer. This is not a laptop. –  Martur Dec 9 '11 at 18:00
    
Edited to remove the nVidia driver and force reinstall of X. –  Bruno Pereira Dec 9 '11 at 19:21
    
This solution helped me on Lenovo t410 (with intel i915 only). Thanks! –  Paweł Nadolski Dec 23 '11 at 13:25
    
Thanks, that worked on sony vaio z31xn –  mreq Apr 15 '12 at 15:35
    
Massive thanks. Worked on Asus A53S - Intel Core i5 w/ Nvidia GEFORCE GT540M –  Jordan Arseno Oct 19 '12 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.