Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've noticed a new release of Picasa (3.9). How would I install it over my current install of Picasa?

share|improve this question
If you have problem with installing:<BR>env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 change it to <BR>env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie7 – Tomasz Matoga Aug 15 '12 at 8:52
some shells don't like the env. As I use ZSH on 64 Bit WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie7 worked for me. – math Nov 1 '12 at 9:17
I have just managed to install Picasa 3.9 in my Ubuntu 12.04.2 LTS 64 bit machine. In order to be able to login to my Google account properly, I installed IE8 using the fast track suggested by @desgua with a slight modification: sudo apt-get install wine winetricks && cd ~/ && wget && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie8 && cp -r ~/.tmp/* ~/.wine/ – regeirk Jun 6 '13 at 23:33

3 Answers 3

up vote 52 down vote accepted

To install Picasa 3.9

1) Install wine and winetricks:
sudo apt-get install wine winetricks

2) Download Picasa 3.9 from google:
cd ~/ && wget

3) Install Picasa with wine:

wine ~/picasa39-setup.exe  

To fix login

Now you have Picasa 3.9 installed but there is a problem if you want to login to Google to upload some pictures, so to fix it do this:

4) Install Internet Explorer 6:
env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6

You will have to click "Next" and "Accept" in a few windows:

enter image description here

5) Copy the installation into wine folder:
cp -r ~/.tmp/* ~/.wine/

6) Done! Now just open Picasa as any other program:

Open Dash and search for Picasa. Click at the top right corner to login:

enter image description here

enter image description here

I) With this method each user will have to run the steps 2 to 5 to get Picasa fully working into his/her user folder. Or ask for he/she to run this once at terminal:

 cd ~/ && wget && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 && cp -r ~/.tmp/* ~/.wine/    

II) If you are feeling lazy, just paste this at terminal and all the steps above will be done for you (as a user specific installation):

 sudo apt-get install wine winetricks && cd ~/ && wget && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 && cp -r ~/.tmp/* ~/.wine/  

III) After the step 5, the file "picasa39-setup.exe" can be deleted:
rm ~/picasa39-setup.exe

And also the folder "~/.tmp":
rm ~/.tmp

IV) To uninstall everything:

sudo apt-get remove --purge wine ; sudo apt-get remove --purge winetricks ; sudo apt-get autoremove ; sudo rm /usr/share/applications/Picasa3.desktop ; rm ~/picasa39-setup.exe ; rm -r ~/.tmp ; rm -r ~/.wine ; rm -r ~/.local/share/applications/wine* ; sed -i '/wine/d' ~/.local/share/applications/mimeinfo.cache

V) I have made two scripts (see it: check and installp) that can check if Picasa is installed and install it if needed with the IE6 to fix the login. The following command will download it from my dropbox with a beautiful icon from qyasogk at Deviantart. After running this command, just search for "Picasa" at Dash, if needed, the install will begin, if don't needed, Picasa will run.

sudo apt-get install wine winetricks ; cd ~/ ; wget -c ; wget -c ; wget -c ; wget -c ; sudo mkdir /opt/picasa ; sudo mv ~/check /opt/picasa/ ; sudo mv ~/installp /opt/picasa/ ; sudo mv ~/Picasa-icon.png /opt/picasa/ ; sudo mv ~/Picasa3.desktop /usr/share/applications/ ; sudo chmod 777 /opt/picasa/check ; sudo chmod 777 /opt/picasa/installp

To remove it:

sudo rm -r /opt/picasa ; sudo rm /usr/share/applications/Picasa3.desktop ; rm ~/.firstpicasarun  
share|improve this answer
The step env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 did not work for me: wine cmd.exe /c echo '%ProgramFiles%' returned empty string --- If I try only winetricks ie6 then I get: "This package does not work on a 64-bit installation" – Felipe Micaroni Lalli Jun 23 at 18:37
I tried to use this script for installing google photos auto backup (which replaced picasa) but it didn't work. Im getting "there was a problem authenticating your account". Any chance you know if this can be fixed? – Shoham Jun 25 at 17:45
i think the problem is the 2 step authentication with Google. Installing ie6 with WINE was a workaround but ie6 isn't installing in some setups. – desgua Jun 28 at 16:47
There is a way to do it with google photos auto backup ... basically you just export & import some registry records from a windows installation to Ubuntu. Full instructions here if someone interested:… – Shoham Jul 5 at 20:26

If you use Picasa 3.9, you will not be able to connect to your Google account. According to Google employee Brian Rose, the authentication mechanism was changed to OAuth using an implementation that is currently not compatible with Wine.

There is an entry in Wine's AppDB for Picasa 3.9, and I submitted a bug report. As a workaround, install Internet Explorer 6 using Winetricks. You have to use the upstream Winetricks script, since the one packaged in Ubuntu has a broken Internet Explorer link.

chmod +x winetricks
WINEPREFIX=~/.wine ./winetricks ie6
share|improve this answer
Great instructions. Instead of IE6.0 work around for google account login. I tried an application specific password using the following link. Worked for me. The link: – user41528 Jan 11 '12 at 18:50
"This package does not work on a 64-bit installation" – matt burns Jan 5 at 12:52

PlayOnLinux supports Picasa 3.9:


PlayOnLinux is a graphical front-end for the Wine software compatibility layer which allows Linux users to install Windows-based video games, as well as many other applications such as Apple iTunes, Safari, Microsoft Office, Microsoft Internet Explorer.


wget -q "" -O- | sudo apt-key add -
sudo wget -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

Search and do what the wizard says:

League of Legends under Ubuntu - EuroBytes Image from: League of Legends under Ubuntu - EuroBytes.


share|improve this answer

protected by Community Jul 7 '12 at 17:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.