Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When using the Zoom function of Compiz, the zoomed-in pixels are anti-aliased (smoothed), which I guess is helpful for accessibility, however I want to actually see an accurate representation of the pixels (for graphic design purposes). Is there a way to disable the anti-alias feature?

share|improve this question
up vote 2 down vote accepted

Which zoom plugin are you using?

ccsm

Only 1 of them has options for linear filtering, so if you are using the Zoom Desktop plugin, disable Linear filter. You'll need CCSM for this sudo apt-get install compizconfig-settings-manager and possibly sudo apt-get install compiz-plugins-extra

ccms2

Also make sure Bicubic filter is not enabled

ccsm3

Note

From this confirmed bug-report:

This answer currently does not apply to 12.04 or later.

share|improve this answer

In 12.04 up to at least 15.10, the only way to disable anti-aliasing in the zoom feature is to disable it altogether at the OpenGL level:

OpenGL > General > Texture Filter = Fast

This has the drawback of disabling anti-aliasing for all other scaled or 3D features, such as the 3D cubes or the Scale plugin (Super+S). Whether this is relevant to you depends on which plugins you use.

As for me, I care more about getting an accurate representation of the individual pixels when I zoom, than to have smooth thumbnails in the Scale view, so I'm glad I could find the global OpenGL option.

In some future release the Enhanced Zoom plugin will hopefully contain a specific Linear Filter option in the Animation tab, as can be seen in the project wiki: http://wiki.compiz.org/Plugins/Ezoom

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.