Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 from a live DVD. Then went for updating through Update Manager. It downloaded everything. During installing them the update manager crashed. It showed the error message:

The package catalog has broken. Installing or removing software is not possible until the package catalog is repaired.

However opting for repair didn't work and it continued showing the notification obstinately. I was undone.

Please show me how I can repair it.

@int_ua

apt-get update -f did not work. Problem still persists.

@freecode

dpkg --configure -a did not remove the broken package. Nevertheless, I found details that the problem might be due to some third-party package. Now, how to check whether I am using any third-party package and if so how to disable them?

share|improve this question
    
Do you get the same result if you run sudo apt-get update? –  int_ua Dec 9 '11 at 12:52
    
open your dash and type "software sources" - you can find any third-party ppa's installed there - untick them to disable them. Rerun sudo apt-get update && sudo apt-get upgrade to check if you have resolved your problem. –  fossfreedom Dec 10 '11 at 16:13
    
@fossfreedomAfter disabling them and running apt-get update && apt-get upgrade I found that the problem is due to unmet dependencies of evolution-data-server : Depends: evolution-data-server-common (= 3.2.2-0ubuntu1~oneiric) but 3.2.0-0ubuntu1 is installed libedataserverui-3.0-1 : Depends: evolution-data-server-common (>= 3.2.2) but 3.2.0-0ubuntu1 is installed. But now, how to remove this unmet dependency. Update manager is not allowing removing or installing anything. I do not know how to tackle it in the terminal. –  Fatdoc Grinning Dec 11 '11 at 1:15
add comment

2 Answers

You can always try going to the command line and trying this command:

sudo dpkg --configure -a

and simply allow the package manager to repair itself. That will usually do the job.

Hope that helps. Have a nice day.

share|improve this answer
add comment

Had the same problem and solved it: I ran software-center in a terminal and looking at the error messages, I did:

sudo chmod a+r /var/cache/apt-xapian-index/index.1/*
sudo chmod a+r /var/lib/apt-xapian-index/*

The command

dpkg -l

produced an error mesage, I solved that with

sudo chmod a+r /etc/dpkg/dpkg.cfg.d/multiarch

And now software-center is running as it should.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.