Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When using the fontsize slider of gnome-tweak or ubuntu-tweak to e.g. 1.6 multiplier within gnome 3.2, suddenly when logging into KDE 4.7 the fonts of native KDE applications like dolphin get messed up. This doesn't happen with all applications but with some (dolphin, amarok, kmail, KDE systemsettings ...).

I tried the setting for GTK-fonts in KDE system-settings to be set to "use my KDE fonts in GTK apps" and also the option "use own font" (maybe mistranslated). To the same effect.

I can change the fontsize for all KDE programs manually to another value, apply the changes, restore the previous settings, apply the changes again an derverything works like expected again.

Once I log out or reboot and login to KDE the fontsizes are messed up again (as if the multiplier applies to some of KDE!).

How can I prevent KDE from loading the gnome fontsize settings and solve this issue?

share|improve this question

1 Answer 1

i used to have KDE and gnome installed together untill i started to get similar problems. it is UNWISE to run to different display managers with the same user. you should create yourself a different user for every environment.

share|improve this answer
    
Thx for your answer, you are probably right, but now I have a lot of personal data and settings to work with. Now I found that the gnome-settings-manager seems to be the one that messes up. It's loaded at KDE startup. If I disable it with the KDE startup settings the problem is gone, but gnome apps start "naked" without any theme applied. –  piedro Dec 9 '11 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.