Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To prevent my mobile beeing mounted as storage , i put the following line in /etc/fstab:

/dev/disk/by-uuid/36DF-0070 /media/diamond vfat  noauto,nouser,defaults  0 0

Nautilus seems to ignore this and tries to mount the device, which is only prevented by using the nousers option (a windows appears, the device can only be mounted by root).

It seems to be a known bug but the mentioned workaround doesn't work for me.

Any suggestions?

share|improve this question

1 Answer 1

You have misunderstood how noauto works.

From fstab man page:

 noauto: do not mount when "mount -a" is given (e.g., at boot time)

It means that the partition would not be mounted at boot time, and is not even taken into consideration when you insert the device containing the partition after the boot.

In older versions of Nautilus, there was an option to set in gconf-editor to not automount inserted devices. Now it is in dconf-editor, in

org.gnome.desktop.media-handling/automount

(thanks to @lgarzo for the information).

share|improve this answer
1  
It is now org.gnome.desktop.media-handling/automount in dconf-editor. –  lgarzo Dec 9 '11 at 12:34
    
@lgarzo: good to know, thanks –  enzotib Dec 9 '11 at 12:53
    
I found the option in dcon-editor: –  Daniel Schmidt Dec 9 '11 at 13:02
    
Thanx , it worx! –  Daniel Schmidt Dec 9 '11 at 13:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.