Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Despite several attempts at a solution, I still can't change the default applications in Ubuntu 11.10. If I change them in system settings they revert back as soon as I close the dialogue. Next time I open the settings, default applications have reverted back to the standards. If I right click a file and try to choose a default application there I get an error message saying "can't create user application configuration folder" etc etc.

I am logged in as the only user created, so I should have rights to change these settings, shouldn't I?

share|improve this question

here's what I've recently found out for this issue: Install Ubuntu-Tweak and there you get an option namely "File Type manager" There you can edit all the default application for all type of files/programs. Give it a try and i'm sure it'll work for you the way it worked for me!

share|improve this answer

If the fault message went on to say Not a directory then simply browse to ~/.local/share and remove, rename or move the file named applications which shouldn't be there and is preventing the creation of an applications directory.

Open a terminal to check is there is a applications file, type on a terminal

nautilus ~/.local/share

or press Ctrl+h with nautilus open and navigate to ~/.local/share.

If there is a file called applications there, rename it, or delete it (if find renaming it more secure, just in case).

share|improve this answer
Sorry, I picked the wrong answer. @moderation: please ignore the flag. – htorque Jan 24 '12 at 23:43

This is just a thought... have you tried in root? do (in terminal)

sudo gedit ~/.local/share/applications/mimeapps.list

then type in your password and then edit your values there. Hope this helps!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.