Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was wondering if it could be added to the right click menu an option to "print" the file without the need to open it and then print it.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted
+50

enter image description here

Once potential solution is to use nautilus-actions to create a right-click menu option in nautilus.

Unfortunately, the version in oneiric causes a segmentation fault. One good third-party PPA you could use is described in this answer.

An alternative is to download the 32bit or 64bit .deb package from the precise repository and install this (sudo dpkg -i [deb-package-name].deb)

to install

Copy and paste line by line the following in a terminal:

sudo add-apt-repository ppa:dr3mro/nautilus-actions-extra
sudo apt-get update
sudo apt-get install nautilus-actions

Now launch the config tool:

nautilus-actions-config-tool

Create a new action called Libreoffice Print

enter image description here

Then enter the the command libreoffice with the parameters -p %F as per this image.

Hint: If you want't you can enter -p %M instead and select Appears if selection has multiple files or folders. Then you can select and print multiple files.

Another Hint: You might want to ristrict the entry to LibreOffice files. So enter *.odt as filename condition.

enter image description here

nautilus refresh

Although I'm not not sure why - if you install the package nautilus-refresh then the nautilus-actions sub-menu is combined with the standard right-click menu option as per the first image in this answer.

sudo apt-get install nautilus-refresh

Save. Run the following for the new menu option to take effect.

nautilus -q
share|improve this answer
1  
A you've been little bit faster than me... ;) Exactly the same solution. But I used %M instead of %f. –  lumbric Dec 27 '11 at 0:35
    
:) many thanks for the extra tip - its a good one! –  fossfreedom Dec 27 '11 at 0:36
    
Yeah, but you'll get the full bounty! Unfair! ;) But another detail: I think you should uncheck "Display item in location context menu". This is the menu when you click on folders, right? With folders it's not working. You'd have to add some kind of wild card maybe. –  lumbric Dec 27 '11 at 0:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.