Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a dual monitor on my fresh Ubuntu 11.10 install. The problem is that it works for a very short time, then the second monitor turns grey.

My videocard is a GeForce 210 1GB DDR3 and the nvidia-current drivers are activated.

share|improve this question
check under the icon of the gear, in the upper right corner, there is a shortcut for the display management, try to set your displays from there. – Micro Dec 8 '11 at 19:46
@Micro when opening the Ubuntu displays manager then only one display is recognized. Though, in the Nividiap-setting i have two displays – Roel Veldhuizen Dec 8 '11 at 22:11
up vote 3 down vote accepted
  1. Open the NVIDIA X Server Settings application. This was installed with your NVidia proprietary drivers.
  2. Navigate to the "X Server Display Configuration" screen.
  3. In the "Display" tab, select the greyed-out monitor with the "Model" selector.
  4. Set the "Configuration" option of that monitor to "TwinView" mode.
  5. Restart your computer.
share|improve this answer

After such a struggle with settings here and settings this I clicked on dash, typed in driver selected additional driver. Here you should see that you 2 options after clicking on it.

  1. NVIDIA accelerated graphics dirver (version current)[Recommended]
  2. NVIDIA accelerated graphics dirver (post-release updates)(version current-updates)

I had 1 selected as this is how I installed my driver initially. This then broke and after a struggle as mentioned above I selected 2 and clicked on activate, restarted my machine and boom. Up and working np. Here is my xorg.conf file paste bin entry

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.