Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Looking at a Samsung Series 7 laptop.. Anyone know if Ubuntu supports AMD Radeon HD 6490M or 6750M?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

The question is not if Ubuntu supports your hardware or not, it is more if your hardware builder has made any drivers for your hardware to be usable in Linux.

The Radeon HD 6750 is officially supported by ATI's Catalyst drivers and the xserver-xorg-video-ati open source drivers.

The Radeon HD 6750M will work even tough you will find your self with a watermark on the right bottom corner of the screen saying your hardware is not supported. That can be fixed following some simple steps.

The Radeon HD 6490 or the 6490M are not officially supported by ATI's Catalyst drivers but the open source xserver-xorg-video-ati driver should work without a problem.

The xserver-xorg-video-ati open source driver will be installed by default once your card is detected, the performance in not au pair with the closed driver but really big improvements are done with each release so its definitely an option.

You can easily toogle between the open source xserver-xorg-video-ati driver and the closed driver by following these steps.

share|improve this answer
    
the whole 6xxxM series is fully supported by the fglrx driver, you can easily check this at the download page from the official website. –  Micro Dec 8 '11 at 20:16
    
That is not correct, please look for any references to the 6490 on the supported hardware list. Its not there, its not officially supported. –  Bruno Pereira Dec 8 '11 at 20:19
2  
I think the point here is that the 6xxxM series is not guaranteed to work, it was released 'as-is'. 6750 however will work without problems. So go ahead and buy the laptop of your choice - but do not be surprised if the drivers are not supported. –  rlemon Dec 8 '11 at 20:48
add comment

[EDIT BELOW, it works!] Short note to say that I never got my Chronos 7 working with fglrx drivers. I've tried Oneiric and Precise, with catalyst 11.2 and more recently 12.1. Currently I have the drivers installed, but I have to delete my xorg.conf in order to get a desktop, which dumps me to a Unity-2d session. My driver, according to my system settings, is blank, which I presume means that I'm on Intel.

If I uninstall the drivers, I get a Unity 3D session using the Intel driver, but then the ATI card runs at full speed constantly, driving the fans at full speed.

Other issues - no control over the backlit keyboard (it's always on), screens brightness resets to full on startup, ignoring your choice/amendments in the display settings and finally, as it's a buttonless trackpad, you'll need to make some tweaks (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/582809) in order to get it working. It's also incredibly insensitive, so you'll have to tweak it again with

synclient FingerLow=3
synclient FingerHigh=8

every login to make it usable without pressing the full pad of your finger in order to move the mouse.

Suspend/resume, WIFI, sound and 1600x900 resolution, however, all work fine.

This laptop is NOT a good choice for Ubuntu. Unity-2d is startlingly poor - no customisation options, so you'll get the whole "FisherPrice" experience - but necessary unless you can put up with the noise of the fans blasting full time.

EDIT : I did eventually get this laptop working reasonably well. FGLRX did install in the end. Despite the multi-arch status of Precise, I ended up doing a sudo apt-get install ia32-libs which then installs a multitude of "redundant" packages. Can't tell if that's really what did the trick, but un-installing FGLRX after that, then re-installing (using the "additional drivers" in system settings and choosing the stable drivers) appeared to do the trick. You also have to link /usr/lib64 to /usr/lib, or the sudo amdconfig --px-dgpu command will fail.

So, what's wrong now? The trackpad still needs the synclient changes and doesn't support click-n-drag although two-finger scrolling is good, as is two-finger tap for right-click. The keyboard backlight is always on and unconfigurable. The brightness of the screen will often reset on boot up to full power. There was also an issue with Pulseaudio, but I think that will be resolved now - certainly the fix on that bug report got me working, as you can see on comment 24.

So conversely then, it's fast, quiet (unless you're playing a game), high resolution, light (for its size), and the battery lasts around 4 hours with light usage (mid-brightness, WIFI on, Bluetooth on, web browsing mainly).

In summary, it's hard work, but a cracking laptop once you get it working. And perhaps the finished 12.04 will work around some of these issues generally.

share|improve this answer
add comment

Yes and you have 3 main options for the ATI video cards under Ubuntu:

  • the radeon package, which is for the really old video card and only provide a basic support for 2D acceleration
  • the fglrx package from the official repository, which contains the official closed source driver for the latest ATI video card but is outdated compared to the third option
  • the official closed source driver from the AMD ATI website and this is your best option http://support.amd.com/us/gpudownload/Pages/index.aspx

for references and documentations you can follow this link http://wiki.cchtml.com/index.php/Main_Page

share|improve this answer
    
This is not correct. –  Bruno Pereira Dec 8 '11 at 20:08
    
the whole 6xxxM series is fully supported by the fglrx driver, you can easily check this at the download page from the official website. –  Micro Dec 8 '11 at 20:16
    
The old radeon package is not for this card so it should not be there, not all the 6000M cards will work since they are not all supported. –  Bruno Pereira Dec 8 '11 at 20:18
    
i think that you have to read the post before making statements, the 6xxxM family does not sound really old for me and for the market. –  Micro Dec 8 '11 at 20:22
    
the thing is you are calling the xserver-xorg-video-radeon driver an old driver that supports "basic support for 2D" which is not true because: a) its not old; b) it has excellent 2D support and limited 3D support. + not all range from the 6000M is supported by the ATI's binaries. –  Bruno Pereira Dec 8 '11 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.