Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I upgraded from 11.04 to 11.10, my login screen reverted back to landscape mode, and only goes to portrait mode (what I want) once I login.

How to make the login screen be in portrait mode?

share|improve this question
1  
Also raised in: bugs.launchpad.net/ubuntu/+source/lightdm/+bug/812171 But tagged as 'invalid' (not a bug). –  david6 Dec 8 '11 at 21:32
add comment

1 Answer

This worked for me on a CLEAN install of 11.10:

  1. BACK UP your xorg.conf file (/etc/X11/xorg.conf)
  2. Again, make sure you performed step 1 above. I can't stress this enough.
  3. Edit your xorg.conf file, adding the following to the "Device" section:

    Option "Rotate" "CCW"

("CCW" is for counter-clockwise. Enter "CW" for clockwise)

  1. Save, and restart X

Side-effect: I assume you have:

Option "RandRRotation" "on"

in your xorg.conf file (I don't kno whow you'd be able to get a portrait display after logging in otherwise). The only side effect I've noticed is that every time you use apt or Synaptic to install anything, and follow the process in the terminal screen, you'll get lots of "RandR extension not found" messages. It hasn't had any detrimental effects on my end.

Hope this helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.