Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is it at all possible to have a forwarded X11 session be styled with something other than the default X button styles? It doesn't even appear to use my server's actual styles seeing as both computers are running Ubuntu 10.10. However, the window on the left is from the local machine, and window on the right is forwarded via ssh -X.

Is there any way to change this behavior to mimic the native button style or change it at all? Thanks.

alt text

share|improve this question
Contrary to what I said in my deleted answer, this should just work. If you run a gnome application using ssh -X, it should automatically use the settings from your local settings daemon. Is there anything unusual about your setup? – sepp2k Oct 21 '10 at 11:05
As sepp2k points out, there are likely different configuration mechanisms at play here: (1) GNOME applications will use gnome-settings-daemon if it's running; (2) GTK applications will use the ~/.gtkrc-2.0 file on the machine they're running on; (3) similarly, Qt/Xaw/Xtoolkit apps have their own (and different!) way of configuring style. What applications are you interested in? – Riccardo Murri Oct 21 '10 at 11:54
up vote 6 down vote accepted

This has apparently been discussed on SuperUser as well; Suppressingfire's answer looks to me like the correct one:

  1. Install your favorite Ubuntu GTK theme on the remote host as well;

  2. Create a ~/.gtkrc-2.0 on the remote host, and include the theme's own gtkrc from it; e.g., if you're running Ubuntu with the ClearLooks theme on the remote host, you can add use this line:

    include "/usr/share/themes/ClearlooksClassic/gtk-2.0/gtkrc";
share|improve this answer
Both answers look to me like they're correct, and I rather think ephemient's answer is the one the OP wants, as it allows him to use his local settings. – sepp2k Oct 21 '10 at 11:18
This one worked best for me. I figured rendering was handled by the remote host. Thanks! – sirlancelot Oct 22 '10 at 3:47
I skipped step 2. and used the lxappearance app (sudo apt-get install lxappearance) to configure the desktop theme. Credit to – ThorSummoner Nov 28 '14 at 23:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.