Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Client: Ubuntu 11.10 64-Bit

Server: VirtualBox Ubuntu 11.10 64-Bit

I would like to start a gnome-session/lightdm-session, but it doesn't work. Even though I'm able to start single programs like Gedit.

Does I have to make specific changes to be able to use a gnome-session through ssh? As far as I have seen in the online tutorials I've read, all you need is:

ssh -X username@ip gnome-session
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I think you are confusing two things:

  • X11 forwarding requires you to connect with the -X (or -Y) switch. (Unless specified in your local ssh_config or remote sshd_config). As you've experienced this will allow you to run almost all programs that require X but as separate application (remember you can background them immediately when invoking the program with a n '&' behind it.

  • You seem to want something akin to a 'remote desktop'. Application along those lines are FreeNX or NeatX by google. Apparently in 11.10, it is now easier to use x2go (see here for some installation instructions).

All of these remote-desktop setups require a bit more setting up. For instance you need a suitable client on the connecting side. But on the other hand, they are generally better than VNC and they are much quicker than running X11 over ssh due to some funky compression. Good luck.

share|improve this answer
    
I tried VNC and x2go. With some trouble I could configure both and run them (x2go needed some extra ssh cfg love). The result is, that I can login and see the Desktop wallpaper and in the case of x2go some files & folder at the Desktop but with neither the full Desktop shell. Seems like logging in as GNOME doesn't work right. –  Paradiesstaub Dec 8 '11 at 20:15
    
It works when using Unity2D && x2go! Thanks for the x2go tip :) –  Paradiesstaub Dec 8 '11 at 21:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.