Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried turning on both the physical hardware switch and the fn, f2 and the same problem persists. I am dual booting with windows 7. it works fine with 7. I consider myself able to navigate most computer problems but not able to write code or completely understand how and where it works. This is my first day with ubuntu.

share|improve this question
we need some hardware and logs to help you - please see this question and answers - add to your question the suggestions please.… – fossfreedom Dec 8 '11 at 16:22
Assuming that you are using 11.10 can you confirm that you have followed the guidance given in the Ubuntu Desktop Guide under networking, web, email & chat, including wireless networking. You find this document by typing help in the dash search bar. – grahammechanical Dec 8 '11 at 18:56

I ran into an issue that reminds me of what you're experiencing. In my case, switching off the wireless with the hardware switch switched off a software switch. Try to type the following command in a terminal: $ sudo rfkill unblock all

That solved the issue for me (with Ubuntu 11.04).

share|improve this answer
Worked for me - I am running a Dell Inspiron 1420 with a physical wireless switch. In my case, I only needed to run "sudo rfkill unblock wifi". – frankadelic Feb 12 '12 at 23:22

There is a bit of a learning curve with a new OS and it is frustrating when your hardware does not work.

Do you know what wireless card you have ? Brand / model ? Once we identify the card we can determine if it is going to be easy or difficult to fix.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.